Bug 906492 - [abrt] fontforge-20120731b-1.fc17: pdf_findobject: Process /usr/bin/fontforge was killed by signal 11 (SIGSEGV)
Summary: [abrt] fontforge-20120731b-1.fc17: pdf_findobject: Process /usr/bin/fontforge...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fontforge
Version: 17
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f67cc3b753d3021d5f5d80b8add...
Keywords: Reopened
: 949287 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-31 17:32 UTC by Joseph O Morrow
Modified: 2013-04-27 23:56 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-04-23 03:35:55 UTC


Attachments (Terms of Use)
File: core_backtrace (1.20 KB, text/plain)
2013-01-31 17:32 UTC, Joseph O Morrow
no flags Details
File: environ (2.22 KB, text/plain)
2013-01-31 17:32 UTC, Joseph O Morrow
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-31 17:32 UTC, Joseph O Morrow
no flags Details
File: backtrace (39.78 KB, text/plain)
2013-01-31 17:32 UTC, Joseph O Morrow
no flags Details
File: cgroup (130 bytes, text/plain)
2013-01-31 17:32 UTC, Joseph O Morrow
no flags Details
File: smolt_data (2.95 KB, text/plain)
2013-01-31 17:33 UTC, Joseph O Morrow
no flags Details
File: executable (18 bytes, text/plain)
2013-01-31 17:33 UTC, Joseph O Morrow
no flags Details
File: maps (28.42 KB, text/plain)
2013-01-31 17:33 UTC, Joseph O Morrow
no flags Details
File: dso_list (4.76 KB, text/plain)
2013-01-31 17:33 UTC, Joseph O Morrow
no flags Details
File: proc_pid_status (779 bytes, text/plain)
2013-01-31 17:33 UTC, Joseph O Morrow
no flags Details
File: open_fds (258 bytes, text/plain)
2013-01-31 17:33 UTC, Joseph O Morrow
no flags Details
File: var_log_messages (314 bytes, text/plain)
2013-01-31 17:33 UTC, Joseph O Morrow
no flags Details

Description Joseph O Morrow 2013-01-31 17:32:47 UTC
Description of problem:
Was in file-select dialog, choosing folders and subfolders, and FontForge suddenly crashed.

Version-Release number of selected component:
fontforge-20120731b-1.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/bin/fontforge
crash_function: pdf_findobject
kernel:         3.7.3-101.fc17.i686.PAE

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 pdf_findobject at parsepdf.c:461
: #2 pdf_findfonts at parsepdf.c:529
: #3 NamesReadPDF at parsepdf.c:2020
: #4 GetFontNames at scripting.c:1634
: #5 WithinList at openfontdlg.c:521
: #6 e_h at openfontdlg.c:556
: #7 _GWidget_Container_eh at gcontainer.c:393
: #8 _GWidget_TopLevel_eh at gcontainer.c:737
: #10 dispatchEvent at gxdraw.c:3869
: #11 GXDrawProcessOneEvent at gxdraw.c:3901

Comment 1 Joseph O Morrow 2013-01-31 17:32:51 UTC
Created attachment 691122 [details]
File: core_backtrace

Comment 2 Joseph O Morrow 2013-01-31 17:32:53 UTC
Created attachment 691123 [details]
File: environ

Comment 3 Joseph O Morrow 2013-01-31 17:32:55 UTC
Created attachment 691124 [details]
File: limits

Comment 4 Joseph O Morrow 2013-01-31 17:32:56 UTC
Created attachment 691125 [details]
File: backtrace

Comment 5 Joseph O Morrow 2013-01-31 17:32:58 UTC
Created attachment 691126 [details]
File: cgroup

Comment 6 Joseph O Morrow 2013-01-31 17:33:00 UTC
Created attachment 691127 [details]
File: smolt_data

Comment 7 Joseph O Morrow 2013-01-31 17:33:02 UTC
Created attachment 691128 [details]
File: executable

Comment 8 Joseph O Morrow 2013-01-31 17:33:03 UTC
Created attachment 691129 [details]
File: maps

Comment 9 Joseph O Morrow 2013-01-31 17:33:05 UTC
Created attachment 691130 [details]
File: dso_list

Comment 10 Joseph O Morrow 2013-01-31 17:33:07 UTC
Created attachment 691131 [details]
File: proc_pid_status

Comment 11 Joseph O Morrow 2013-01-31 17:33:08 UTC
Created attachment 691132 [details]
File: open_fds

Comment 12 Joseph O Morrow 2013-01-31 17:33:10 UTC
Created attachment 691133 [details]
File: var_log_messages

Comment 13 Paul Flo Williams 2013-02-02 03:46:28 UTC
In the Open dialog, you had the filter set to "Extract from PDF", didn't you?

Unfortunately, FontForge doesn't support some common compression techniques used in modern PDFs (version 1.5 and above) and, as you have seen, makes a very bad attempt.

This is the case even for the very latest upstream code, I'm afraid, so this is unlikely to be fixed any time soon.

Comment 14 Paul Flo Williams 2013-04-08 10:11:15 UTC
Although this has been submitted upstream and no progress has been made, we have a way forward locally, so I'm reopening this. Although correctly processing newer PDFs is a large job, I can stop FontForge crashing by at least recognising the PDFs that will crash. I'll be applying a patch shortly.

Comment 15 Paul Flo Williams 2013-04-08 10:29:22 UTC
*** Bug 949287 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2013-04-17 06:50:29 UTC
fontforge-20120731b-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fontforge-20120731b-7.fc19

Comment 17 Fedora Update System 2013-04-17 06:51:27 UTC
fontforge-20120731b-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fontforge-20120731b-5.fc18

Comment 18 Fedora Update System 2013-04-17 06:53:06 UTC
fontforge-20120731b-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fontforge-20120731b-5.fc17

Comment 19 Fedora Update System 2013-04-17 16:23:16 UTC
Package fontforge-20120731b-7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fontforge-20120731b-7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5863/fontforge-20120731b-7.fc19
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2013-04-23 03:35:57 UTC
fontforge-20120731b-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2013-04-27 23:55:03 UTC
fontforge-20120731b-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2013-04-27 23:56:24 UTC
fontforge-20120731b-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.