Bug 906556 - Eclipse tooltips are unusable with new Adwaita color theme
Summary: Eclipse tooltips are unusable with new Adwaita color theme
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-themes-standard
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cosimo Cecchi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 912936 (view as bug list)
Depends On:
Blocks: 903352 989497
TreeView+ depends on / blocked
 
Reported: 2013-01-31 21:44 UTC by Jeff Johnston
Modified: 2013-07-29 11:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 989497 (view as bug list)
Environment:
Last Closed: 2013-02-28 07:08:02 UTC
Type: Bug


Attachments (Terms of Use)
screenshot (105.19 KB, image/png)
2013-02-01 11:04 UTC, Cosimo Cecchi
no flags Details

Description Jeff Johnston 2013-01-31 21:44:45 UTC
Description of problem:

In F18, the default colors for tooltips have changed in the Adwaita theme.  The old background used to be a light blue and the foreground, black.  Eclipse, both from Fedora and upstream is not somehow recognizing the system colors for tooltip windows and is writing them with black/grey foreground text which makes them impossible to read.  In addition, html text links are defaulted to a dark purple and they are also extremely difficult to read on a black background.

While it is possible to try and fix Fedora Eclipse, it may be difficult to get a fix into upstream at this point as Juno SR2 has just put out RC2 and SR2 releases on Feb 22nd.  I will post an upstream bug to see if it is possible to fix it.

If the changes to the Adwaita theme are intended and desired, is it possible to have an AdWaita-classic theme that Eclipse users can use?  Switching to high contrast mode works, but it is rather ugly looking.

Version-Release number of selected component (if applicable):
gnome-themes-standard-3.6.2-1.fc18.x86_64

How reproducible:

1. Install the eclipse-cdt package on f18.

2. Start eclipse (eclipse -data /home/YOURID/workspace-test &)

3. Go to menu File->New->Other Project->C/C++->C++ Project

4. Name the project hello and choose Executable->Hello World ANSI C++ Project and choose the Linux gcc toolchain.  Hit Finish.  If asked to switch to C/C++ Perspective, do so.

5. Replace the hello.cpp file contents in the editor with:

#include <iostream>
using namespace std;
class A {
public:
	int v;
	int w;
	int x;
};

int main() {
	int k = 9;
	A *p = new A();
	p->w = 5;
	p->x = 4;
	cout << "!!!Hello World!!!" << k << endl; // prints !!!Hello World!!!
	return 0;
}

6. Hit the Hammer icon to build the project or click Project->Build Project

7. Open the project up in the left tree view and find the Binaries folder and open it.

8. Right click on the binary and select Debug as...-> Local C/C++ Application

9. Step over lines in the debugger until you get to the line p->x = 4;

10. Hover over p and you will see that the class is shown with the top line selected in blue, but subsequent lines are hidden written in black.

Comment 1 Cosimo Cecchi 2013-02-01 11:03:57 UTC
Thanks for the detailed instructions to reproduce.
This was indeed fixed with the fix I mention in https://bugzilla.redhat.com/show_bug.cgi?id=903352#c4 - attaching a screenshot for reference.

I was waiting for a new GTK2 release before releasing a final 3.6 update for gnome-themes-standard. I'll try to get this moving in the next couple of days.

Comment 2 Cosimo Cecchi 2013-02-01 11:04:49 UTC
Created attachment 691524 [details]
screenshot

Screenshot for reference.

Comment 3 Cosimo Cecchi 2013-02-20 16:53:52 UTC
*** Bug 912936 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2013-02-25 17:23:30 UTC
gnome-themes-standard-3.6.5-1.fc18,gtk2-2.24.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-themes-standard-3.6.5-1.fc18,gtk2-2.24.16-1.fc18

Comment 5 Fedora Update System 2013-02-27 02:45:39 UTC
Package gnome-themes-standard-3.6.5-1.fc18, gtk2-2.24.16-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-themes-standard-3.6.5-1.fc18 gtk2-2.24.16-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3155/gnome-themes-standard-3.6.5-1.fc18,gtk2-2.24.16-1.fc18
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-02-28 07:08:05 UTC
gnome-themes-standard-3.6.5-1.fc18, gtk2-2.24.16-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.