Bug 90660 - Shrink-wrapped software pack missing vital information
Shrink-wrapped software pack missing vital information
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rhl-ig-x86 (Show other bugs)
9
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Sandra Moore
Sandra Moore
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-12 01:14 EDT by Bret Busby
Modified: 2014-08-04 18:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-13 09:48:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bret Busby 2003-05-12 01:14:46 EDT
Description of problem:
Neither the cover of the shrink-wrapped pack, nor the Installation Guide,
include a statement of the Minimum System Requirements for installing and
running the software, and the Installation Guide does not include the text-based
installation procedure.


Version-Release number of selected component (if applicable):
rhl-ig-x86(EN)-9-Print-RHI (2003-01-16T18:24-0400)
from shrink-wrap pack
1-58569-329-4


How reproducible:
Fully


Steps to Reproduce:
1.Read shrink wrapped software pack cover
2.Buy shrinkwrapped software pack
3.Read included Installation Guide
    
Actual results:
Unsuccessful installation of Red Had Linux 9 - RH Linux 9 useless for task as
server OS


Expected results:
Successful installation of Red Hat Linux 9; RH Linux appropriate for task as
server OS


Additional info:
We bought Red Hat Linux 9, to upgrade our server (running Red Hat Linux 6.2 on a
Pentium MMX with 32 MB RAM). The shrink-wrapped software pack did not show any
Minimum System Requirements on the outside of the pack. We had no reason to
believe that the server would not meet the minimum system requirements. The
Installation Guide did not include a statement of the Minimum System
Requirements. We tried to instal Red Hat Linux on the server. We got an error
message stating that the computer had insufficient RAM for a graphical
installation process, so the text-based installation process was attempted. The
Installation Guide had no information (as it does for the graphical
installation; step by step, with screen dumps), for the text-based installation
process. Network card and mouse not detected. No network component included in
installation procedure. Later found Minimum System Requirements elsewhere.
Server does not meet and cannot meet Minimum System Requirements. Software
useless for task.
Comment 1 Sandra Moore 2003-05-12 11:59:39 EDT
Hello,

Thanks for writing and for your feedback.

On the bottom of the Red Hat Linux 9 shrink-wrapped boxed set, there is a
listing of minimum requirements which say:

CPU
Minimum: Pentium-class
Recommended for text-mode: 200MHz Pentium-class or better
Recommended for graphical: 400Mhz Pentium II or better

Hard disk space
Custom Installation (minimum): 475MB
Server: 850MB
Personal Desktop: 1.7GB
Workstation: 2.1GB
Custom Installation (everything): 5.0GB

Memory
Minimum for text-mode: 64MB
Minimum for graphical: 128MB
Recommended for graphical: 192MB

As for the text-mode installation instructions, we have not included these
instructions for several releases. The text-mode installation program has been
updated to follow the same path as the graphical install, so that a user could
use the graphical installation instructions and still receive the help they
need. The Installation Guide states in several places that it explains how to
perform a custom installation of Red Hat Linux from the CD-ROM, using the
graphical, mouse-based installation program (including the first paragraph of
Chapter 3). We have so few cases of the installation program not working in
graphical mode these days, that it doesn't make sense any more for us to include
the step-by-step text-mode installation instructions (especially when
considering the limited page count allowed for the Installation Guide.

Best regards,
Sandra

Comment 2 Bret Busby 2003-05-12 21:18:59 EDT
The shrink-wrapped pack for which I gave the ISBN number, as mentioned in the
Installation Guide, did NOT display the Minimum System Requirements. I suggest
finding a shrink-wrapped Red Hat Linux 9 pack such as I specified, and
physically looking at the pack. The one that we purchased, did NOT include the
Minimum System Requirements specification, on the outside of the pack, on any of
the contents of the pack, or, in the Installation Guide.

Please check the shrink-wrapped pack with the ISBN number that I quoted. I
followed the instructions in the Installation Guide, in making the bug report.

The barcode number for the shrink-wrapped Red Hat Linux 9 pack to which I
referred, is 6-38347-50290-3. Please check the shrink-wrapped pack with that bar
code number and ISBN number.

Regarding the lack of the text-mode installation instructions; the computer on
which the operating system was to be installed, is a server/gateway, used
primarily as a dialup/gateway/firewall/printserver for a small LAN, for which
minimal system requirements (not the Minimum System Requirements for RH Linux 9)
are generally adequate. 

It appears from the above response to the bug report, that Red Hat 9 cannot be
used for a server/gateway computer such as I have described, (apart from not
meeting the Minimum System Requirements), as the system resources required for
the graphical installation of Red Hat 9, are far beyond what is required for the
minimal requirements for such a server.

The computer that we have been using for a number of years, for this purpose, is
a Pentium 200MMX based computer, with 32MB RAM, which has been running Red Hat
Linux 6.2 quite happily for the task, and adequately performing in its role,
with no performance problems.

It appears from the response above, that an alternative to Red Hat Linux 9,
should be used for a small server installation, and, it appears that Red Hat
expects that Red Hat 9 should not be used for operating small gateway/servers.

Oh, and the mouse (apart from the network card), could not be got to work with
Red Hat 9.

Because Red Hat 9 failed to detect the network card, there was no opportunity to
install a driver for the network card, or configure the network, during the
installation process, in spite of the assurance stated at the top of page 47 of
the Installation Guide. We were consequently unable to access the network.
Perhaps, the text-based installation does not include network access, or
installation of network devices? The Tip at the bottom of that page, was not
successful, as we could not access the network, using Red Hat Linux 9.

With all of this, we have had to revert to using Red Hat Linux 6.2, as the more
appropriate server OS, as Red Hat Linux 9 appears incapable of operating the
server/gateway. The total Red Hat Linux 6.2 installation on the server, is about
690MB, from df -h.
Comment 3 Sandra Moore 2003-05-13 09:48:21 EDT
The Red Hat Linux Product Manager and I have reviewed both versions of the Red
Hat Linux 9 boxed set (the standard and professional versions). Both of the
boxed sets that are produced by Red Hat, Inc. include the minimum hardware
requirements on the bottom of the box (the bottom of the box is the only
location these requirement can be found). I'm not sure if you have aquired a
boxed set that was not made by Red Hat, Inc., but it does not seem that you have
an official Red Hat Linux product from your description. 

I'm not sure why you had so much trouble with hardware and installing Red Hat
Linux 9. Please review the following links to see if they will help meet your needs:

Hardware Compatibility Lists --  http://hardware.redhat.com/hcl/
Red Hat Enterprise Linux AS -- http://www.redhat.com/software/rhel/as/
Red Hat Linux 9 Errata -- https://rhn.redhat.com/errata/rh9-errata.html


Since I was unable to reproduce your problems with the boxed set and was able to
verify that the boxed sets produced by Red Hat, Inc. do include the minimum
requirements information, I am closing this bug report. Best regards!
Comment 4 David Wilson 2003-05-15 22:41:50 EDT
Bret is correct - the Pocket Book Edition of RedHat Linux 9 (7 cds + install 
book - not a "boxed" set as there is no cardboard box) does not state minimum 
system requirements where they can be seen before breaking the shrink wrap. 

Here are the ISBN and part numbers from the Australian edition I checked:

ISBN 1-58569-329-4
BOX0029AP
RHF0120AP
Comment 5 Sandra Moore 2003-05-16 10:54:55 EDT
Bret and I chatted via email to gain a better understanding of this situation.
The Red Hat Product Management teams are now aware of this issue and are working
with their global counterparts to ensure this information is included in future
products for all regions.


Note You need to log in before you can comment on or make changes to this bug.