Bug 90663 - env -i links -dump segfaults
Summary: env -i links -dump segfaults
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: elinks   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-12 08:36 UTC by Joe Orton
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version: 0.4.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-12 10:15:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remove egd support (838 bytes, patch)
2003-05-12 09:43 UTC, Joe Orton
no flags Details | Diff

Description Joe Orton 2003-05-12 08:36:46 UTC
Description of problem:
"env -i links -dump" segfaults

Version-Release number of selected component (if applicable):
elinks-0.4.2-1

How reproducible:
Always

Steps to Reproduce:
1. env -i links -dump http://localhost/
 
Actual results:
Segmentation fault

Expected results:
No segfault!

Additional info:

Comment 1 Joe Orton 2003-05-12 09:05:20 UTC
Even segfaults with:

  env -i links -no-home -dump http://localhost/

The problem is the call

  RAND_egd(RAND_file_name(f_randfile, sizeof(f_randfile)))

which segfaults since RAND_file_name returns NULL if $HOME is not set.  RAND_egd
is not necessary for a Linux system anyway - I'm testing a patch to remove this
section of code.


Comment 2 Joe Orton 2003-05-12 09:43:33 UTC
Created attachment 91614 [details]
remove egd support

This patch removes EGD support, which is unnecessary on Linux, and fixes the
segfault.

Comment 3 Tim Waugh 2003-05-12 10:15:33 UTC
Thanks for the patch.  Fixed package will appear in rawhide shortly.


Note You need to log in before you can comment on or make changes to this bug.