Bug 906690 - The grub miss the backup version after upgrade in legacy machines.
The grub miss the backup version after upgrade in legacy machines.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: Regression, ZStream
Depends On:
Blocks: 913691
  Show dependency treegraph
 
Reported: 2013-02-01 04:00 EST by cshao
Modified: 2014-01-21 14:24 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.0-6.el6
Doc Type: Bug Fix
Doc Text:
After upgrading the hypervisor on a legacy (non-EFI) machine, the /liveos directory was unmounted, so users could not access the backed up version of the hypervisor. Now, a non-EFI installation reads grub.conf for changes before it unmounts the /liveos directory, so the hypervisor backups are still available after upgrade.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:24:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt.log (64.67 KB, text/plain)
2013-02-01 04:02 EST, cshao
no flags Details

  None (edit)
Description cshao 2013-02-01 04:00:50 EST
Description of problem:
The grub miss the backup version after upgrade in legacy(non-uefi) machines.

e.g. 
1. upgrade form rhev-hypervisor6-6.4-20130130.0.0.el6 to itself.
2. upgrade from rhev-hypervisor6-6.3-20121120.0.el6_3 to rhev-hypervisor6-6.4-20130130.0.0.el6

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20130130.0.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor6-6.3-20121120.0.el6_3 to legacy machine.
2. Upgrade rhevh to latest version via tui / cmd / rhevm.
3. focus on grub.
  
Actual results:
1. The grub miss the backup version after upgrade in legacy(non-uefi) machines.
2. No such issue in UEFI machine.

Expected results:
Gurb can save the backup version part after upgrade.

Additional info:
Comment 1 cshao 2013-02-01 04:02:51 EST
Created attachment 691449 [details]
ovirt.log
Comment 11 cshao 2013-10-24 07:34:34 EDT
rhev-hypervisor6-6.5-20131017.0
ovirt-node-3.0.1-4.el6.noarch

Gurb can save the backup version part after upgrade.
Enter the backup version can successful.

So the bug is fixed, change bug status to VERIFIED.
Comment 13 errata-xmlrpc 2014-01-21 14:24:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.