Bug 90670 - gnome numeric keypad problem with LANG=fr_FR
Summary: gnome numeric keypad problem with LANG=fr_FR
Status: CLOSED DUPLICATE of bug 101046
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gtk2 (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-12 13:23 UTC by Daniel Roche
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Roche 2003-05-12 13:23:39 UTC
Description of problem:
When LANG is set to fr_FR (either fr_FR.UTF-8, fr_FR.ISO-8859-1 or fr_FR@euro)
the dot(.) on numeric keypad give a comma(,) on gnome applications.

Version-Release number of selected component (if applicable):
RedHat 9, gedit 2.2.0 , gnome-terminal 2.2.1

How reproducible:
Everytime

Steps to Reproduce:
1.
 set language as french ( fr_FR ) 
2.
 launch a gnome-terminal or a gedit
3.
 hit the dot(.) key on the numeric keypad
    
Actual results:
 you get a comma(,) 

Expected results:
 it should be a dot(.)

Additional info:
 non gnome application ( xterm, kde, mozilla ... ) give the correct character
 it is not a matter of X11 configuration since xev give also the correct key :

KeyPress event, serial 25, synthetic NO, window 0x2200001,
    root 0x7c, subw 0x2200002, time 769140, (33,40), root:(44,580),
    state 0x10, keycode 91 (keysym 0xffae, KP_Decimal), same_screen YES,
    XLookupString gives 1 bytes:  "."
 
KeyRelease event, serial 25, synthetic NO, window 0x2200001,
    root 0x7c, subw 0x2200002, time 769192, (33,40), root:(44,580),
    state 0x10, keycode 91 (keysym 0xffae, KP_Decimal), same_screen YES,
    XLookupString gives 1 bytes:  "."

Comment 1 Owen Taylor 2003-08-27 21:32:44 UTC

*** This bug has been marked as a duplicate of 101046 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:59 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.