Bug 906873 - /api/version says "Headpin"
/api/version says "Headpin"
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Adam Price
SAM QE List
:
Depends On:
Blocks: sam13-tracker 999177
  Show dependency treegraph
 
Reported: 2013-02-01 13:27 EST by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 999177 (view as bug list)
Environment:
Last Closed: 2013-10-01 07:04:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sthirugn: automate_bug? (jweiss)


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2013-02-01 13:27:44 EST
Description of problem:


Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.1-15h.el6_3 

Actual results:

[jweiss@blinky workspace]$ curl -k -u admin:admin https://cloud-qe-8.idm.lab.bos.redhat.com/sam/api/version 
{"name":"Headpin","version":"1.2.1-15h.el6_3"}

Expected results:
{"name":"Subscription Asset Manager","version":"1.2.1-15h.el6_3"}


Additional info:
Comment 1 Mike McCune 2013-03-27 11:12:31 EDT
is this a regression?  I don't think the API has ever been keyed off the deployment location or this has ever been branded to say the product name beyond headpin or katello.

if not I'd argue that the API is always going to be headpin or katello and we shouldn't brand this.
Comment 2 Jeff Weiss 2013-03-27 11:16:04 EDT
That's fine but CFSE says "Cloud Forms System Engine" (or something like that).

That is why I thought SAM should say SAM.  It looked like someone had deliberately changed CFSE.
Comment 4 Adam Price 2013-08-15 13:56:07 EDT
we'll say 'headpin' or 'katello'
Comment 5 Adam Price 2013-08-15 16:11:59 EDT
https://github.com/Katello/katello/pull/2767
Comment 7 sthirugn@redhat.com 2013-08-20 17:18:00 EDT
Verified.

Version tested:
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-cert-consumer-cloud-qe-21.idm.lab.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 9 errata-xmlrpc 2013-10-01 07:04:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.