Bug 9069 - RH6.1 installation corrupting partition table
RH6.1 installation corrupting partition table
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-02 11:30 EST by Jeff
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-22 18:13:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff 2000-02-02 11:30:14 EST
After unsuccessfully attempting to install RH6.1 into a logical partition
in the extended partition, Partition Magic refuses to run because Disk
Druid altered the Logical Partition's linked list so that the partitions
have  different physical and logical orders (error 120).

Scenario:
14 gigabyte hard drive with 2 primary partitions (one 3gb fat32 with
current installation of Win98, one 700mb fat16 with installation of Win98
from previous motherboard left hidden in semi-perpetuity until I have time
to satisfy myself that I'll never need anything off of it again), and an
extended partition with 3 logical partitions and 2gb free space at the
beginning into which I intended to create two more logical partitions: the
ext2 partition for Linux and the swapfile partition. I created the
swapfile first (I think Disk Druid assigned it /hda9), then created the
ext2 partition (I think Disk Druid then re-named the swapfile /hda10 and
named the ext2 partition /hda9). Why that order? So I could assign the
swapfile 128mb (bumped up to 133 by Disk Druid, probably just a 1024 vs
1000 nomenclature difference), then assign the remainder of the free space
to the ext2 partition (actually I told DD to make it 1mb and grow to fill
the remaining space).

During the first attempt, Disk Druid seemed to run OK, but a fatal error
occurred during the format attempt.

I restarted and tried again, and the same thing happened.

For the third attempt, I tried booting and installing from the RH6.0 CD on
the theory that I might have just burned a bad copy from the 6.1 ISO file.
This time, it made it past the formatting stage, but reported that I
didn't have enough space to install the files I'd selected. The amount of
space needed seemed to be approximately the same amount of space as the
files I'd selected, implying that the available free space on the new ext2
partition was somewhere around 0-1 megabytes.

At that point, I called a friend who uses Linux as his primary OS. His
theory was that I was probably straddling or beyond the 1024 cylinder
limit. At that point, I booted back into Windows & ran Partition Magic 4
in an effort to clean up the mess, delete the two new partitions, and
shuffle things around a bit to make room at the beginning of the disk for
Linux.

PM refused to touch the disk because of an error 120. Apparently, it was
unhappy because the logical partitions weren't linked in physical order,
i.e., logical partition #4 (swapfile) began at a lower cylinder than
logical partitions 1, 2, and 3 (all fat32); partition #5 (ext2) began at a
lower cylinder than #4 (swapfile).

This particular bug doesn't even touch upon the more serious issue of why
the installer wasn't able to continue with the installation (perhaps
because the partition was beyond the 1024-cylinder limit & neither disk
druid nor installer provided any warning that Bad Things would happen if
the installation continued). However, the search I did on DejaNews
(for "Disk Druid" & 120) turned up enough similar experiences from others
who were unable to run Partition Magic (or FDISK) after using Disk Druid
to show that this particular bug isn't particularly rare. While it's not
immediately fatal (Windows still runs fine), it's going to cause a lot of
inconvenience because apparently the only way to get rid of the error 120
once and for all is to back up everything, wipe the entire hard drive, and
restore everything.
Comment 1 Michael Fulbright 2000-02-03 12:04:59 EST
There are two issues here - I will address the Partition magic related issue
first.

Disk druid follows the behavior of the linux fdisk program when it allocates
new logical partitions - I know partition magic advertises that it now works
with Linux so I would think they would have tested it against fdisk. Perhaps
there is an updated version of Partition Magic that might fix this issue...

The second issue is why the installer fails with your original attempt.

What is the fatal error you get when the installer fails?
Comment 2 Jeff 2000-02-03 17:23:59 EST
I think part of the problem might have been that the extended partition was
type f instead of type 5. After I backed up, wiped, and restored the hard
drive, I created the ext2 and swapfile partitions using partition magic as the
first two logical partitions within the extended partition. This time, I made
sure I only used disk druid to set the mount point. The installation seemed to
complete, but for some reason networking never got installed (in particular,
ifconfig and ifup were both nowhere to be found).

When I tried to re-run the RH6.1 installer and perform an upgrade, it told me
that there was no Linux installation to upgrade. A few more trips to the RH
knowledge base later & armed with the knowledge that the original RH6.1
installer got confused by extended partitions of type f, I tried using the
Anaconda boot disk and update disk. No luck; it still didn't see the Linux
installation. At that point I was mad enough to throw caution to the wind and
use fdisk to temporarily change the partition type of the extended partition
from type f to type 5 & tried again. This time, the upgrade attempt worked. It
installed about 49 RPMS totaling 128mb (presumably that it skipped installing
the first time around, since I didn't actually tell it to install anything
new), and the result was a working installation. Just to be safe & keep Windows
happy, I ran fdisk again and changed the extended partition back to type f. So
far, it's still working.

Suggestion to pass on for future consideration:

define a URL on your site (readmefirst.redhat.com, maybe?) that will always
contain a brief summary of current installation issues with the most recent CD
(especially issues those that are new to the current release and those that can
result in a failed installation or hard drive corruption, even if the person
doing the installation has installed Linux dozens of times before in the past
and wouldn't be expecting anything unusual to come up and bite him this time
around), as well as patches and updates likely to be of immediate interest to
someone who wants to install RH Linux _RIGHT NOW_, but could be persuaded to
download a few files first and endure creating a few floppies if somebody tells
him it's really important to do so instead of just booting from the CD.

Note You need to log in before you can comment on or make changes to this bug.