Bug 90691 - rpmbuild: getOutputFrom(): Broken pipe
rpmbuild: getOutputFrom(): Broken pipe
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-12 11:46 EDT by Nathalie Viollet
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-21 20:24:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathalie Viollet 2003-05-12 11:46:34 EDT
Description of problem:
When I try to build my software RPM, the build end by : (with rpmbuild -ba)

Processing files: CMU-MONITORING-3-0_12052003_15h46m51
Provides: libFileLockTools.so libReentrantTools.so libcmuclient.so libcmucomms.s
o libcmucomms_udp.so libcmudebug.so libcmufile.so libcmulineparser.so libcmuserv
er.so libcmutools.so libpthreadTools.so
Requires(interp): /bin/sh /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHave
Prefix) <= 4.0-1
Requires(post): /bin/sh
Requires(preun): /bin/sh
Requires: /bin/sh libFileLockTools.so libReentrantTools.so libc.so.6 libc.so.6(G
LIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.2) libc.so.6(GLIBC_2.1.3) lib
c.so.6(GLIBC_2.3.2) libcmucomms.so libcmucomms_udp.so libcmudebug.so libcmufile.
so libcmulineparser.so libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.
0(GLIBC_2.1) libpthreadTools.so
Checking for unpackaged file(s): /usr/lib/rpm/check-files %{buildroot}
getOutputFrom(): Broken pipe

The problem is note systematic: when running 100 times the command it works 
about 2 times ?????
The packages can be build fine on redhat 7.3, 7.2 and 8.0

Version-Release number of selected component (if applicable):
rpm-build-4.2-0.69

How reproducible:
98 times out of 100

Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Jeff Johnson 2003-05-21 20:24:58 EDT
Yup.

Either add a BuildRoot: directive, or disable the check files
helper by adding to spec file
    %undefine __check_files
Comment 2 Paul Berger 2003-05-23 14:10:07 EDT
I have the same problem with RH9. The only solution that works is disabling the 
## %__check_files         /usr/lib/rpm/check-files %{buildroot}
in the /usr/lib/rpm/macros file or 
 %undefine __check_files 
in local ~/.rpmmacros.

Paul


Note You need to log in before you can comment on or make changes to this bug.