Bug 906912 - ppp radius plugin breaks on new keywords in radius config file
Summary: ppp radius plugin breaks on new keywords in radius config file
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ppp
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Sekletar
QA Contact: Jaroslav Aster
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-01 21:52 UTC by Charlie Brady
Modified: 2015-03-16 08:13 UTC (History)
2 users (show)

(edit)
Cause: 
Parser for radius client config file is too strict.

Consequence:
Error is returned when radius client config file contains options which ppp's radius plugin can't recognize.

Fix: 
Configuration parser for radius client configuration now skips over directives which are unrecognized.

Result:
When configuration for authentication method based on radius is now populated from configuration file only known directives are considered while unknown are skipped without reporting errors in configuration.
Clone Of:
: 906913 (view as bug list)
(edit)
Last Closed: 2015-03-16 08:13:47 UTC


Attachments (Terms of Use)
Patch to skip unrecognised directives when parsing radius file (565 bytes, patch)
2013-02-01 21:52 UTC, Charlie Brady
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0685 normal SHIPPED_LIVE ppp bug fix and enhancement update 2015-03-16 12:13:39 UTC

Description Charlie Brady 2013-02-01 21:52:51 UTC
Created attachment 691752 [details]
Patch to skip unrecognised directives when parsing radius file

If ppp is configured to use the radius plugin for authentication:

...
plugin radius.so
radius-config-file /etc/radiusclient-ng/radiusclient.conf
...

and radiusclient.conf contains 'bindaddr *' (as it does in radiusclient-ng-0.5.6-8.fc18.i686.rpm), then: authentication fails with these log messages:

> Nov 23 10:46:11 vucc2 pppd[1171]: /etc/radiusclient-ng/radiusclient.conf: line 75: unrecognized
> keyword: bindaddr
> Nov 23 10:46:11 vucc2 pppd[1171]: RADIUS: Can't read config file
> /etc/radiusclient-ng/radiusclient.conf 

The problem is that the config file parser in the radius plugin of pppd is too strict. Instead of ignoring configuration directives that it does not recognise, and does not care about, it stops parsing the file, and returns an error, and remains itself unconfigured.

Patch attached.

Comment 1 Charlie Brady 2013-02-01 21:54:41 UTC
Patch was long ago submitted to linux-ppp mailing list, but that list appears to be unmonitored by the ppp maintainers.

http://marc.info/?l=linux-ppp&m=134636974704703

Comment 3 Michal Sekletar 2013-07-31 14:29:21 UTC
This is already fixed in fedora, fix maybe included in some future maintenance release of RHEL6.

Comment 4 RHEL Product and Program Management 2013-10-13 23:59:57 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 10 errata-xmlrpc 2015-03-16 08:13:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0685.html


Note You need to log in before you can comment on or make changes to this bug.