Bug 90697 - post scriplet fails
post scriplet fails
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: librsvg2 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-12 12:30 EDT by Sepp Rudel
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 15:35:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sepp Rudel 2003-05-12 12:30:08 EDT
Description of problem:
While I was updating from RHL7.3->RHL9 with apt (yea, I know, not supported by
RH, but read on...), librsvg2 gave following error:

  57:librsvg2               ########################################### [  8%]
Cannot load loader /usr/lib/gtk-2.0/2.2.0/loaders/libpixbufloader-png.so

Probably caused by the fact that also RPM containing
/usr/lib/gtk-2.0/2.2.0/loaders/libpixbufloader-png.so was about to be
updated after librsvg2 during the same "rpm -Uvh" run. This might well happen
also with up2date/rpm -Fvh/yum/etc.


Version-Release number of selected component (if applicable):
All, I presume.

How reproducible:
Always.

Steps to Reproduce:
1.update librsvg2 and RPMs containing
/usr/lib/gtk-2.0/2.2.0/loaders/libpixbufloader-png.so in the same run
    
Actual results:
error messages printed.


Expected results:
no error messages printed.


Additional info:
Probably not critical but worth fixing IMHO.
Comment 1 Sepp Rudel 2003-05-13 07:36:14 EDT
D'oh! Wrong component, now changed. librsvg2 is the problematic case.
Comment 2 Alexander Larsson 2003-05-16 08:40:43 EDT
Hmm. Interesting. It probably needs some sort of PreReq.
Comment 3 Joseph Tate 2003-11-21 02:07:16 EST
Still exists in Fedora Core 1
Comment 4 Joseph Tate 2003-11-21 02:07:55 EST
Doh, disregard that.  I'm seeing something else.
Comment 5 Matthias Clasen 2004-06-23 15:35:44 EDT
I've changed Requires: gtk2 to PreReq: gtk2 which should fix it.

Note You need to log in before you can comment on or make changes to this bug.