Bug 907004 - vncviewer -listen option not recognized
vncviewer -listen option not recognized
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
18
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 906953 (view as bug list)
Depends On:
Blocks: 906953
  Show dependency treegraph
 
Reported: 2013-02-02 09:55 EST by Cédric OLIVIER
Modified: 2013-04-30 19:53 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 20:11:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Cédric OLIVIER 2013-02-02 09:55:52 EST
Description of problem: Listen option is not recognized in this new revision, but always in vncviewer man page and usage.


Version-Release number of selected component (if applicable): tigervnc.x86_64 1.2.80-0.8.20130124svn5036.fc18

Command used by gitso, is "vncviewer -listen". With an old tigervnc rpm (tigervnc-1.1.0-6.1) it works fine :

$ vncviewer -listen

Visionneur TigerVNC pour la version 1.1.0 du serveur X - Paquetage construit le « Jul 23 2012 20:06:27 »
Copyright (C) 1999-2011 TigerVNC Team and many others (see README.txt)
Voir http://www.tigervnc.org pour plus d'informations sur TigerVNC.

Sat Feb  2 15:39:14 2013
 main:        Listening on port 5500

But with a recent rpm (tigervnc-1.2.80-0.8.20130124svn5036) it doesn't work :

vncviewer -listen

TigerVNC Viewer 64-bit v1.2.80 (20130124)
Built on Jan 24 2013 at 13:04:01
Copyright (C) 1999-2011 TigerVNC Team and many others (see README.txt)
See http://www.tigervnc.org for information on TigerVNC.

usage: vncviewer [parameters] [host:displayNum] [parameters]
       vncviewer [parameters] -listen [port] [parameters]
Comment 1 Marc Ponschab 2013-02-02 16:07:03 EST
This bug is ignored upstream since more than one year:

http://sourceforge.net/tracker/index.php?func=detail&aid=3477054&group_id=254363&atid=1126848

Really sad since remmina-plugins-vnc does not work with "UltraVNC Single Click" :(
Comment 2 Terje Røsten 2013-02-04 04:44:37 EST
How is this possible?

If not this is fixed, package must be downgraded to FC17 version.
Comment 3 Davide Repetto 2013-02-05 03:43:06 EST
Before it worked by removing the dash before listen as in:
[code]vncviewer listen[/code]

but now it gives the following error:

[davide@dave ~]$ vncviewer listen

TigerVNC Viewer 32-bit v1.2.80 (20130124)
Built on Jan 24 2013 at 13:03:40
Copyright (C) 1999-2011 TigerVNC Team and many others (see README.txt)
See http://www.tigervnc.org for information on TigerVNC.

Tue Feb  5 09:38:56 2013
 CConn:       unable to resolve host by name: Nome o servizio sconosciuto
Comment 4 Jan ONDREJ 2013-02-07 05:20:00 EST
Same problem here. I vote for downgrade too, if this is not fixable.
Comment 5 David Jansen 2013-02-26 07:37:14 EST
Following the link posted here, I saw upstream has it marked as a duplicate of http://sourceforge.net/tracker/?func=detail&aid=3429667&group_id=254363&atid=1126848 and that issue has recent updates, including a not that it should be fixed in trunk.
Comment 6 Adam Tkac 2013-02-26 09:19:43 EST
(In reply to comment #5)
> Following the link posted here, I saw upstream has it marked as a duplicate
> of
> http://sourceforge.net/tracker/
> ?func=detail&aid=3429667&group_id=254363&atid=1126848 and that issue has
> recent updates, including a not that it should be fixed in trunk.

It is already fixed in upstream. I'm preparing bigger update for tigervnc which will also fix this issue but update is currently blocked on bug #896648 which is not solved, yet. However I can build package with "-listen" support in koji if you cannot wait for some more time...
Comment 7 Terje Røsten 2013-02-28 04:30:41 EST
> However I can build package with "-listen"
> support in koji if you cannot wait for some more time...

Yes, please :-) That will help testing too.
Comment 8 Fedora Update System 2013-03-12 15:13:31 EDT
tigervnc-1.2.80-0.9.20130307svn5060.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/tigervnc-1.2.80-0.9.20130307svn5060.fc18
Comment 9 Jeffrey C. Ollie 2013-03-13 16:20:11 EDT
*** Bug 906953 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2013-03-13 22:48:39 EDT
Package tigervnc-1.2.80-0.9.20130307svn5060.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tigervnc-1.2.80-0.9.20130307svn5060.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3797/tigervnc-1.2.80-0.9.20130307svn5060.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-03-14 20:11:24 EDT
tigervnc-1.2.80-0.9.20130307svn5060.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.