Bug 907143 - Cannot dnf history undo last
Cannot dnf history undo last
Status: CLOSED DUPLICATE of bug 878348
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-02-03 06:50 EST by Michael Monreal
Modified: 2013-02-04 04:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-02-04 04:18:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2013-02-03 06:50:24 EST
"dnf history list" and "dnf history info x" seem to work, but "dnf history undo x" (or last) does not:

[mimox ~]$ sudo /usr/bin/dnf history undo last
Undoing transaction 17, from Sun Feb  3 12:39:29 2013
    Install mingw32-wine-gecko-1.8-1.fc18.noarch          @fedora
    Install mingw64-wine-gecko-1.8-1.fc18.noarch          @fedora
    Install wine-1.5.18-1.fc18.x86_64                     @fedora
    Install wine-alsa-1.5.18-1.fc18.x86_64                @fedora
    Install wine-capi-1.5.18-1.fc18.i686                  @fedora
    Install wine-capi-1.5.18-1.fc18.x86_64                @fedora
    Install wine-cms-1.5.18-1.fc18.i686                   @fedora
    Install wine-cms-1.5.18-1.fc18.x86_64                 @fedora
    Install wine-common-1.5.18-1.fc18.noarch              @fedora
    Install wine-core-1.5.18-1.fc18.i686                  @fedora
    Install wine-core-1.5.18-1.fc18.x86_64                @fedora
    Install wine-courier-fonts-1.5.18-1.fc18.noarch       @fedora
    Install wine-desktop-1.5.18-1.fc18.noarch             @fedora
    Install wine-filesystem-1.5.18-1.fc18.noarch          @fedora
    Install wine-fonts-1.5.18-1.fc18.noarch               @fedora
    Install wine-ldap-1.5.18-1.fc18.i686                  @fedora
    Install wine-ldap-1.5.18-1.fc18.x86_64                @fedora
    Install wine-marlett-fonts-1.5.18-1.fc18.noarch       @fedora
    Install wine-mono-0.0.8-1.fc18.noarch                 @fedora
    Install wine-ms-sans-serif-fonts-1.5.18-1.fc18.noarch @fedora
    Install wine-openal-1.5.18-1.fc18.i686                @fedora
    Install wine-openal-1.5.18-1.fc18.x86_64              @fedora
    Install wine-pulseaudio-1.5.18-1.fc18.i686            @fedora
    Install wine-pulseaudio-1.5.18-1.fc18.x86_64          @fedora
    Install wine-small-fonts-1.5.18-1.fc18.noarch         @fedora
    Install wine-symbol-fonts-1.5.18-1.fc18.noarch        @fedora
    Install wine-system-fonts-1.5.18-1.fc18.noarch        @fedora
    Install wine-systemd-1.5.18-1.fc18.noarch             @fedora
    Install wine-tahoma-fonts-1.5.18-1.fc18.noarch        @fedora
    Install wine-twain-1.5.18-1.fc18.i686                 @fedora
    Install wine-twain-1.5.18-1.fc18.x86_64               @fedora
    Install wine-wow-1.5.18-1.fc18.x86_64                 @fedora
Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 303, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 131, in main
    result, resultmsgs = cli.do_commands()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1478, in do_commands
    return command.doCommand(self.base.basecmd, self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 2269, in doCommand
    ret = self._hcmd_undo(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 2135, in _hcmd_undo
    if self.base.history_undo(old):
  File "/usr/lib/python2.7/site-packages/dnf/yum/__init__.py", line 2877, in history_undo
    if self.remove(pkgtup=pkg.pkgtup):
TypeError: remove() got an unexpected keyword argument 'pkgtup'
Comment 1 Ales Kozumplik 2013-02-04 04:18:01 EST

'dnf history undo' is not yet supported and ends with all sorts of tracebacks. Closing this as a dup of the original report, you can track progress on this bug there.

*** This bug has been marked as a duplicate of bug 878348 ***

Note You need to log in before you can comment on or make changes to this bug.