Bug 907162 - Root Password required for Poweroff and Restart
Root Password required for Poweroff and Restart
Status: CLOSED DUPLICATE of bug 890827
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-03 09:04 EST by Cedric Sodhi
Modified: 2013-02-05 11:48 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 11:48:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cedric Sodhi 2013-02-03 09:04:29 EST
Ocasionally, F18 asks for the Root/Sudo password when instructed to shutdown or restart, claiming that the operation could not be performed while other users are logged in.

This may also happen after the computer has been started and should be shut down without having done anything. Clearly, in that situation there is no other user logged in - or at least not from the user's perspective, who want's to shut down his computer.

Needless to mention, that if this is due to something like automatic updates being performed as root in the background, this is still a bug. The user of a desktop distribution must not be prevented from shutting down the PC. Least of all, left uninformed about the reason for the shutdown to fail.
Comment 1 Cedric Sodhi 2013-02-03 09:11:28 EST
Closely related, when the user chooses "cancel" when prompted for the Root password, he is prompted again. Choosing "cancel" a second time logs out the user but GDM never appears, the screen remains without any shell and the cursor as a spinner.

At that point, the user has to fall back to TTY.
Comment 2 Cedric Sodhi 2013-02-03 09:13:23 EST
Please change Severity to either High or Urgent.
Comment 3 Cedric Sodhi 2013-02-03 14:20:53 EST
Moved to Consolekit
Comment 4 Lennart Poettering 2013-02-04 13:03:22 EST
This is probably caused by cron jobs which run in their own logind sessions.

systemd git will no longer considered cronjobs sessions capable of blocking shutdown.
Comment 5 Michal Schmidt 2013-02-05 11:48:40 EST
> Please change Severity to either High or Urgent.

These Bugzilla fields are not used very often by Fedora developers.


Please try with systemd from updates-testing:
https://admin.fedoraproject.org/updates/FEDORA-2013-1590/systemd-197-1.fc18.2

I'm assuming this the same as bug 890827.

*** This bug has been marked as a duplicate of bug 890827 ***

Note You need to log in before you can comment on or make changes to this bug.