Bug 90727 - switching between system with a KVM
switching between system with a KVM
Status: CLOSED DUPLICATE of bug 89948
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
Blocks: 977110
  Show dependency treegraph
Reported: 2003-05-12 20:19 EDT by David O. York
Modified: 2013-07-01 16:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:52:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David O. York 2003-05-12 20:19:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
I have just updated from 8.0 to 9.0.  I have 4 systems with one monitor that 
corrects the systems through a KVM switch that is used to go to each system as 
needed.  This setup worked well with the 8.0 version, but will not work with 
the 9.0 version.  Here is what happens:  after the systems are up and you 
switch between any two of them the mouse will NOT work. Everything else works 
find but the drive for the mouse has something wrong with it.  If their is some 
thing that can be set on my side to fix this please let me know.  I think the 
driver has the problem through.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Have mult. systems
2.use one monitor
3.KVM switch(Data Transfer Switch)
the system were setup normally, this happens when all systems are login to some 
account and is switch from one system to another - it happen everytime.

Actual Results:  The mouse is not usable at all, thus thw system is not usable.

Expected Results:  You should be able to switch between any systems at 
anytime.  This could be done while I used the 8.0 version of your system.

Additional info:
Comment 1 Brent Fox 2003-05-22 12:05:27 EDT
My guess is that the new version of XFree86 that shipped in RHL 9 may have
changed the way that it handles KVMs.  Many KVMs are notorious for using
nonstandard ways of repeating the mouse input signals, but your case is a little
strange in that it worked with 8.0 but not with 9.

I'm transferring this bug to XFree86 and see if Mike has any input here.
Comment 2 Mike A. Harris 2003-05-22 16:10:00 EDT
XFree86 doesn't handle KVMs.  From an electronic or mechanical standpoint,
a KVM basically unplugs the mouse and plugs it into another computer.  The
mechanical ones are horrible as hell and can even fry the hardware.  The
electronic ones vary greatly in how they handle the electronic switching,
and how they handle the connections to the other computers that are also
plugged in, including how they repeat the signals as Brent suggests.

KVMs are totally unsupported, even if they just happened to luckily work
in a previous release, they're still unsupported.

*** This bug has been marked as a duplicate of 89948 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:52:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.