Bug 907290 - No "drive_add"/"drive_del" related QMP commands to hot plug/unplug disk
No "drive_add"/"drive_del" related QMP commands to hot plug/unplug disk
Status: CLOSED DUPLICATE of bug 889051
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-03 22:20 EST by Qunfang Zhang
Modified: 2013-02-04 06:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-04 06:31:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2013-02-03 22:20:36 EST
Description of problem:
In the current rhel7 qemu-kvm, there's no "__com.redhat_drive_add"/"drive_add" and "__com.redhat_drive_del"/"drive_del" qmp commands so can not do hot plug and unplug disk operations.

Luiz mentioned in bz 889051 that the "__com.redhat_*" commands are rhel6.4 specified. And if finally there's no "__com.redhat_*" commands in rhel7.0, we need to add "drive_add"/"drive_del" commands to qmp. Otherwise (if rhel7.0 has "__com.redhat_*" commands we also need to have it for qmp as well.
Create this bug to track this issue.

Version-Release number of selected component (if applicable):
kernel-3.7.0-0.33.el7.x86_64
qemu-kvm-1.3.0-3.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot guest with qmp.

2. Connect to qmp server and query the qmp commands.
 {"execute":"qmp_capabilities"}
{"return": {}}

{"execute":"query-commands"}

3.
  
Actual results:
There's no "__com.redhat_drive_add"/"drive_add" and "__com.redhat_drive_del"/"drive_del" qmp commands so can not do disk hot plug/unplug operations.

Expected results:
Need to include commands to do disk hot plug and unplug.

Additional info:
Comment 2 Luiz Capitulino 2013-02-04 06:31:53 EST
Qunfang, we can use bug 889051 for this, there's no need to create a new one.

*** This bug has been marked as a duplicate of bug 889051 ***

Note You need to log in before you can comment on or make changes to this bug.