Bug 907299 - Change Password Screen - Save button should be completely disabled until 'Password' and 'Confirm Password' are entered
Change Password Screen - Save button should be completely disabled until 'Pas...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
All All
unspecified Severity low
: rc
: ---
Assigned To: Katello Bug Bin
Tazim Kolhar
: Triaged
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-02-03 23:28 EST by sthirugn@redhat.com
Modified: 2016-04-25 20:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:04:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Save Button Enabled after entering password (69.56 KB, image/png)
2013-08-06 04:02 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description sthirugn@redhat.com 2013-02-03 23:28:14 EST
Description of problem:
The Save button should be completely disabled until 'Password' and 'Confirm Password' are entered


Version-Release number of selected component (if applicable):
* candlepin-0.7.23-1.el6_3.noarch
* candlepin-cert-consumer-cloud-qe-8.idm.lab.bos.redhat.com-1.0-1.noarch
* candlepin-tomcat6-0.7.23-1.el6_3.noarch
* elasticsearch-0.19.9-5.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.2.1-1h.el6_3.noarch
* katello-cli-1.2.1-12h.el6_3.noarch
* katello-cli-common-1.2.1-12h.el6_3.noarch
* katello-common-1.2.1-15h.el6_3.noarch
* katello-configure-1.2.3-3h.el6_3.noarch
* katello-glue-candlepin-1.2.1-15h.el6_3.noarch
* katello-headpin-1.2.1-15h.el6_3.noarch
* katello-headpin-all-1.2.1-15h.el6_3.noarch
* katello-selinux-1.2.1-2h.el6_3.noarch
* thumbslug-0.0.28-1.el6_3.noarch
* thumbslug-selinux-0.0.28-1.el6_3.noarch

How reproducible:
Always

Steps to Reproduce:
1. Launch SAM UI
2. Click Forgot Password
3. Click on the link from the Password Reset email received
4. Start entering new Password.  Notice that the 'Save' button is disabled with a notification message 'Passwords do not match'
5. Now without entering 'Confirm Password' field, try one of the following:
--> Click enter to submit the page
--> Click on the disabled-like 'Save' button
  
Actual results:
The page gets submitted without date in 'Confirm Password'

Expected results:
The 'Save' button should be completely disabled and the following should not work:
--> User trying to submit the page by clicking Enter
--> User trying to click on the disabled-like 'Save' button

Additional info:
Comment 2 Tom McKay 2013-07-23 15:51:35 EDT
This behaves as desired now: Save button is disabled until both password fields match.
Comment 3 Bryan Kearney 2013-08-02 14:52:58 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 4 Tazim Kolhar 2013-08-06 04:02:53 EDT
Created attachment 783234 [details]
Save Button Enabled after entering password

VERIFIED :

# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-common-1.4.3-5.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-cli-common-1.4.3-4.el6sat.noarch
katello-glue-elasticsearch-1.4.3-5.el6sam_splice.noarch
katello-headpin-all-1.4.3-5.el6sam_splice.noarch
katello-cli-1.4.3-4.el6sat.noarch
katello-glue-candlepin-1.4.3-5.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-5.el6sam_splice.noarch
Comment 6 errata-xmlrpc 2013-10-01 07:04:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.