Bug 9073 - statically linked pthread library does not work, dynamic works fine
Summary: statically linked pthread library does not work, dynamic works fine
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-02 19:09 UTC by Christof Ameye
Modified: 2016-11-24 14:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-14 18:02:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christof Ameye 2000-02-02 19:09:41 UTC
I had a problem with the pthread library:

I had a large program (source code), which I can't give, it linked the
pthread library statically, and ran fine on some older version of RedHat
Linux. After recompiling it on RedHat 6.1, it did not execute any line of
code in the main() (same sources that worked before),  Using a debugger, it
seemed that the code was locked on a mutex at startup (I saw it on the
stack, which contained none of the cpp or c files in our program). I was
very astonishing. The solution was not to link statically the pthread
library but do it dynamically (-lptread). And everything ran fine after
that. So this is probably a bug in the static version of the ptread
library. I posted a message on the comp.programming.threads newsgroup
before we found the solution, look there for more information (on 1 feb
2000).

Comment 1 Cristian Gafton 2000-05-22 14:53:59 UTC
assign to jakub

Comment 2 Stephen John Smoogen 2003-01-24 23:46:41 UTC
Please check to see if this problem is still existant in the latest Red Hat
release. Also check to see if the problem occurs with Red Hat's 8.0.93 beta
product as it uses a new threading model and code.

Comment 3 Jay Turner 2003-04-14 18:02:29 UTC
Closing out due to bit-rot.


Note You need to log in before you can comment on or make changes to this bug.