Bug 907407 - RHQ master build fails starting - Failed to load module: deployment.rhq.ear.rhq-enterprise-server-ejb3.jar:main
RHQ master build fails starting - Failed to load module: deployment.rhq.ear....
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
4.5
All All
urgent Severity urgent (vote)
: ---
: RHQ 4.6
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-04 05:13 EST by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 05:56:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-02-04 05:13:22 EST
Description of problem: I have troubles starting or installing latest RHQ server.


Version-Release number of selected component (if applicable):
RHQ 4.6.0 #611 rev: 982fb93fc5e406808e9297975b30f461cee7ff0a

How reproducible:always


Steps to Reproduce:
1. download build zip and install rhq
2. installation fails
  
Actual results:

04:30:53,905 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC00001: Failed to start service jboss.module.service."deployment.rhq.ear.rhq-enterprise-serve
r-ejb3.jar".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.rhq.ear.rhq-enterprise-server-ejb3.jar".main: Failed to load module:
deployment.rhq.ear.rhq-enterprise-server-ejb3.jar:main
        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:91) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.6.0_24]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.6.0_24]
        at java.lang.Thread.run(Thread.java:679) [rt.jar:1.6.0_24]
Caused by: org.jboss.modules.ModuleLoadException: Error loading module from /home/hudson/rhq-server-4.6.0-SNAPSHOT/modules/org/rhq/oracle/main/module.xml
        at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:292)
        at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:242)
        at org.jboss.modules.LocalModuleLoader.parseModuleInfoFile(LocalModuleLoader.java:138)
        at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:122)
        at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275)
        at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222)
        at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:94)
        at org.jboss.modules.ModuleLoader.preloadExportedModule(ModuleLoader.java:233)
        at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:246)
        at org.jboss.as.server.moduleservice.ServiceModuleLoader.preloadModule(ServiceModuleLoader.java:160) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:204)
        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:76) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
        ... 5 more
Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[4,54]
Message: Failed to add resource root 'ojdbc6-11.2.0.3.0.jar' at path 'ojdbc6-11.2.0.3.0.jar'
        at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:898)
        at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:854)
        at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:676)
        at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:548)
        at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:287)
        ... 16 more



Expected results:


Additional info:
Comment 1 Jay Shaughnessy 2013-02-05 12:03:47 EST
master commit bef0cee698306aa8732b7fed719746742fe72783
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Tue Feb 5 11:55:49 2013 -0500

Server JAR has a dependency on the OJDBC driver because Quartz sometimes needs
to load a BLOB class from the driver. Postgres installs will not have (and
don't need) the Oracle driver, so we declared the dependency "optional" in
jboss-deployment-structure.xml.  But "optional" just means AS7 will ignore the
fact that the module may not exist at all.  Our build and install  process
is simplified by always creating the oracle driver module structure. But "optional"
will not ignore the fact that the module directory is empty (no jar file). So,
this commit ensures an empty/mock OJDBC driver jar will be placed in the
module directory if the driver is not available at build time.

The JAR has a readme file inside describing the process of how to install
a real driver (by providing a wiki link).  We felt it was easier to provide
the whole structure and just let users drop in the real driver as opposed to
not providing the module structure at all, and making them build it.  For users
following the Oracle setup/prerequiste docs the steps are unchanged. For postgres
installs these changes should just make things work.
Comment 2 Jay Shaughnessy 2013-02-06 11:11:11 EST
master commit 885fdf4e857f1a97220b4636abf15dad0d3b1cfa
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Wed Feb 6 11:08:14 2013 -0500

    A fix to the original fix
Comment 3 Jirka Kremser 2013-02-06 12:59:54 EST
master
http://git.fedorahosted.org/cgit/rhq/rhq.git/diff/?id=520ffcbc8

time:    Wed Feb 6 18:58:15 2013 +0100
commit:  520ffcbc8072c485be0ccf6011ff81928dbe22a5
author:  Jirka Kremser - jkremser@redhat.com
message: [Bug 907407 - RHQ master build fails starting - Failed to load module: deployment.rhq.ear.rhq-enterprise-server-ejb3] The dummy oracle driver was created by 7zip, now it is plain old .zip renamed to .jar
Comment 4 Libor Zoubek 2013-02-08 09:14:30 EST
verified on Version: 4.6.0-SNAPSHOT Build Number: 61c60d0

Note You need to log in before you can comment on or make changes to this bug.