This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 90742 - building glibc-2.3.2-27.9 breaks with glibc-2.3.2-11.9
building glibc-2.3.2-27.9 breaks with glibc-2.3.2-11.9
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-13 01:13 EDT by Bill
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-13 17:00:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill 2003-05-13 01:13:49 EDT
Description of problem: 
Downloaded glibc-2.3.2-27.9.src.rpm from 
ftp://people.redhat.com/jakub/glibc/errata/9/glibc-2.3.2-27.9.src.rpm and tried 
to build it.  After several hours, the error comes back "configure: error: 
compiler support for __thread is required". 
 
Version-Release number of selected component (if applicable): 
glibc-2.3.2-11.9 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Download SRPM of glibc-2.3.2-27.9 
2. Try to build it on a fresh upgrade to Red Hat 9 from Red Hat 8.0 using 
Athlon architecture as target: 
rpm -ba --target athlon glibc-9.spec 
     
Actual results: 
configure: error: compiler support for __thread is required 
 
Expected results: 
Expected it to build the glibc rpms 
 
Additional info:
Comment 1 Jeff Johnson 2003-05-13 17:00:44 EDT
Yes, but this is not an rpm problem. You need
a build environment and/or package configured appropriately
for your athlon.

Reopen a bug against glibc if necessary.

Note You need to log in before you can comment on or make changes to this bug.