Bug 907437 - SELinux is preventing /usr/libexec/colord from 'open' accesses on the file /run/systemd/sessions/2.
SELinux is preventing /usr/libexec/colord from 'open' accesses on the file /r...
Status: CLOSED DUPLICATE of bug 903173
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6cfe37451978e05b331d31f6741...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-04 06:47 EST by Pascal94
Modified: 2013-02-04 06:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-04 06:52:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pascal94 2013-02-04 06:47:25 EST
Description of problem:
SELinux is preventing /usr/libexec/colord from 'open' accesses on the file /run/systemd/sessions/2.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que colord devrait être autorisé à accéder open sur 2 file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep colord /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:colord_t:s0
Target Context                system_u:object_r:systemd_logind_sessions_t:s0
Target Objects                /run/systemd/sessions/2 [ file ]
Source                        colord
Source Path                   /usr/libexec/colord
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           colord-0.1.28-1.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-74.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.7.5-201.fc18.x86_64 #1 SMP Mon
                              Jan 28 19:54:41 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-02-04 07:46:01 CET
Last Seen                     2013-02-04 07:46:01 CET
Local ID                      501194d2-c481-478b-8467-5c611829e286

Raw Audit Messages
type=AVC msg=audit(1359960361.435:346): avc:  denied  { open } for  pid=1791 comm="colord" path="/run/systemd/sessions/2" dev="tmpfs" ino=19378 scontext=system_u:system_r:colord_t:s0 tcontext=system_u:object_r:systemd_logind_sessions_t:s0 tclass=file


type=SYSCALL msg=audit(1359960361.435:346): arch=x86_64 syscall=open success=no exit=EACCES a0=15cf230 a1=80000 a2=1b6 a3=238 items=0 ppid=1 pid=1791 auid=4294967295 uid=998 gid=997 euid=998 suid=998 fsuid=998 egid=997 sgid=997 fsgid=997 ses=4294967295 tty=(none) comm=colord exe=/usr/libexec/colord subj=system_u:system_r:colord_t:s0 key=(null)

Hash: colord,colord_t,systemd_logind_sessions_t,file,open

audit2allow

#============= colord_t ==============
allow colord_t systemd_logind_sessions_t:file open;

audit2allow -R

#============= colord_t ==============
allow colord_t systemd_logind_sessions_t:file open;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.7.5-201.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-02-04 06:52:09 EST

*** This bug has been marked as a duplicate of bug 903173 ***

Note You need to log in before you can comment on or make changes to this bug.