Bug 907465 - engine: zombie tasks are not cleared when we cannot find master domain
engine: zombie tasks are not cleared when we cannot find master domain
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.2
x86_64 Linux
unspecified Severity high
: ---
: 3.2.0
Assigned To: Yair Zaslavsky
Dafna Ron
infra
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-02-04 08:28 EST by Dafna Ron
Modified: 2016-02-10 14:40 EST (History)
13 users (show)

See Also:
Fixed In Version: sf8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logs (102.83 KB, application/x-gzip)
2013-02-04 08:28 EST, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11892 None None None Never

  None (edit)
Description Dafna Ron 2013-02-04 08:28:10 EST
Created attachment 692720 [details]
logs

Description of problem:

I had some tasks that became zombies and I moved my host to a different DC. 
the tasks, although zombie, could not be cleaned until I reconnected the pool about a week later. 

Version-Release number of selected component (if applicable):

si26.1

how reproducible:

Steps to Reproduce:
1. run several live storage migration tasks and restart vdsm 
2. put host in maintenance
3. create a new pool with the same host
4. wait for the tasks to become zombie tasks

Actual results:

engine fails to clean the zombie tasks if we cannot find master domain

Expected results:

we should be able to clean the tasks from the db since the tasks are already zombie tasks. 

Additional info: logs
Comment 1 Barak 2013-02-10 06:19:23 EST
The problem is that when we reach a zombi state, we should not depend on whether there is an active SPM for clearing this task because:

- it should be cleaned ... too old
- in case no spm exist .. those tasks will not appear in it's task list there 
  for no cancel task API will be used.
Comment 3 Dafna Ron 2013-04-14 07:01:05 EDT
verified on sf13.1
I had zombie tasks and they were cleaned after 50 hours even after  I changed the DC. 
no errors in the engine log.
Comment 4 Itamar Heim 2013-06-11 05:27:54 EDT
3.2 has been released
Comment 5 Itamar Heim 2013-06-11 05:31:24 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 05:47:12 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.