Bug 907477 - can't rebuild ppl in fedora-rawhide
can't rebuild ppl in fedora-rawhide
Status: CLOSED DUPLICATE of bug 905420
Product: Fedora
Classification: Fedora
Component: ppl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Roberto Bagnara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-04 09:06 EST by Dick Marinus
Modified: 2013-02-04 10:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-04 10:13:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dick Marinus 2013-02-04 09:06:30 EST
$ wget http://kojipkgs.fedoraproject.org/packages/ppl/1.0/3.fc19.3/src/ppl-1.0-3.fc19.3.src.rpm
$ mock -r fedora-rawhide-x86_64 ppl-1.0-3.fc19.3.src.rpm
...
In file included from checked.defs.hh:30:0,
                 from checked.cc:25:
mp_std_bits.defs.hh:47:7: error: redefinition of 'class std::numeric_limits<__gmp_expr<__mpz_struct [1], __mpz_struct [1]> >'
 class numeric_limits<mpz_class> {
       ^
In file included from checked.defs.hh:29:0,
                 from checked.cc:25:
/usr/include/gmpxx.h:3269:21: error: previous definition of 'class std::numeric_limits<__gmp_expr<__mpz_struct [1], __mpz_struct [1]> >'
   template <> class numeric_limits<mpz_class>
                     ^
In file included from checked.defs.hh:30:0,
                 from checked.cc:25:
mp_std_bits.defs.hh:108:7: error: redefinition of 'class std::numeric_limits<__gmp_expr<__mpq_struct [1], __mpq_struct [1]> >'
 class numeric_limits<mpq_class> {
       ^
In file included from checked.defs.hh:29:0,
                 from checked.cc:25:
/usr/include/gmpxx.h:3306:21: error: previous definition of 'class std::numeric_limits<__gmp_expr<__mpq_struct [1], __mpq_struct [1]> >'
   template <> class numeric_limits<mpq_class>
                     ^
make[3]: *** [checked.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
In file included from checked.defs.hh:30:0,
                 from Checked_Number.defs.hh:28,
                 from Checked_Number.cc:25:
mp_std_bits.defs.hh:47:7: error: redefinition of 'class std::numeric_limits<__gmp_expr<__mpz_struct [1], __mpz_struct [1]> >'
 class numeric_limits<mpz_class> {
       ^
In file included from checked.defs.hh:29:0,
                 from Checked_Number.defs.hh:28,
                 from Checked_Number.cc:25:
/usr/include/gmpxx.h:3269:21: error: previous definition of 'class std::numeric_limits<__gmp_expr<__mpz_struct [1], __mpz_struct [1]> >'
   template <> class numeric_limits<mpz_class>
                     ^
In file included from checked.defs.hh:30:0,
                 from Checked_Number.defs.hh:28,
                 from Checked_Number.cc:25:
mp_std_bits.defs.hh:108:7: error: redefinition of 'class std::numeric_limits<__gmp_expr<__mpq_struct [1], __mpq_struct [1]> >'
 class numeric_limits<mpq_class> {
       ^
In file included from checked.defs.hh:29:0,
                 from Checked_Number.defs.hh:28,
                 from Checked_Number.cc:25:
/usr/include/gmpxx.h:3306:21: error: previous definition of 'class std::numeric_limits<__gmp_expr<__mpq_struct [1], __mpq_struct [1]> >'
   template <> class numeric_limits<mpq_class>
                     ^
make[3]: *** [Checked_Number.lo] Error 1
In file included from checked.defs.hh:30:0,
                 from Checked_Number.defs.hh:28,
                 from intervals.defs.hh:30,
                 from Interval.defs.hh:30,
                 from Concrete_Expression.defs.hh:29,
                 from Concrete_Expression.cc:25:
mp_std_bits.defs.hh:47:7: error: redefinition of 'class std::numeric_limits<__gmp_expr<__mpz_struct [1], __mpz_struct [1]> >'
 class numeric_limits<mpz_class> {
       ^
In file included from meta_programming.hh:27:0,
                 from C_Integer.hh:27,
                 from globals.defs.hh:28,
                 from Concrete_Expression.defs.hh:28,
                 from Concrete_Expression.cc:25:
/usr/include/gmpxx.h:3269:21: error: previous definition of 'class std::numeric_limits<__gmp_expr<__mpz_struct [1], __mpz_struct [1]> >'
   template <> class numeric_limits<mpz_class>
                     ^
In file included from checked.defs.hh:30:0,
                 from Checked_Number.defs.hh:28,
                 from intervals.defs.hh:30,
                 from Interval.defs.hh:30,
                 from Concrete_Expression.defs.hh:29,
                 from Concrete_Expression.cc:25:
mp_std_bits.defs.hh:108:7: error: redefinition of 'class std::numeric_limits<__gmp_expr<__mpq_struct [1], __mpq_struct [1]> >'
 class numeric_limits<mpq_class> {
       ^
In file included from meta_programming.hh:27:0,
                 from C_Integer.hh:27,
                 from globals.defs.hh:28,
                 from Concrete_Expression.defs.hh:28,
                 from Concrete_Expression.cc:25:
/usr/include/gmpxx.h:3306:21: error: previous definition of 'class std::numeric_limits<__gmp_expr<__mpq_struct [1], __mpq_struct [1]> >'
   template <> class numeric_limits<mpq_class>
                     ^
make[3]: *** [Concrete_Expression.lo] Error 1
In file included from checked.defs.hh:30:0,
                 from Checked_Number.defs.hh:28,
                 from Coefficient.types.hh:16,
                 from Coefficient.defs.hh:27,
                 from Box.defs.hh:29,
                 from Box.cc:25:
mp_std_bits.defs.hh:47:7: error: redefinition of 'class std::numeric_limits<__gmp_expr<__mpz_struct [1], __mpz_struct [1]> >'
 class numeric_limits<mpz_class> {
       ^
In file included from checked.defs.hh:29:0,
                 from Checked_Number.defs.hh:28,
                 from Coefficient.types.hh:16,
                 from Coefficient.defs.hh:27,
                 from Box.defs.hh:29,
                 from Box.cc:25:
/usr/include/gmpxx.h:3269:21: error: previous definition of 'class std::numeric_limits<__gmp_expr<__mpz_struct [1], __mpz_struct [1]> >'
   template <> class numeric_limits<mpz_class>
                     ^
In file included from checked.defs.hh:30:0,
                 from Checked_Number.defs.hh:28,
                 from Coefficient.types.hh:16,
                 from Coefficient.defs.hh:27,
                 from Box.defs.hh:29,
                 from Box.cc:25:
mp_std_bits.defs.hh:108:7: error: redefinition of 'class std::numeric_limits<__gmp_expr<__mpq_struct [1], __mpq_struct [1]> >'
 class numeric_limits<mpq_class> {
       ^
In file included from checked.defs.hh:29:0,
                 from Checked_Number.defs.hh:28,
                 from Coefficient.types.hh:16,
                 from Coefficient.defs.hh:27,
                 from Box.defs.hh:29,
                 from Box.cc:25:
/usr/include/gmpxx.h:3306:21: error: previous definition of 'class std::numeric_limits<__gmp_expr<__mpq_struct [1], __mpq_struct [1]> >'
   template <> class numeric_limits<mpq_class>
                     ^
make[3]: Leaving directory `/builddir/build/BUILD/ppl-1.0/src'
make[2]: Leaving directory `/builddir/build/BUILD/ppl-1.0/src'
make[1]: Leaving directory `/builddir/build/BUILD/ppl-1.0'
make[3]: *** [Box.lo] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.1xeMd9 (%build)
    bogus date in %changelog: Wed Feb 17 2009 Karsten Hopp <karsten@redhat.comt> 0.10-7
    bogus date in %changelog: Thu Nov 04 2008 Roberto Bagnara <bagnara@cs.unipr.it> 0.10-3
    bogus date in %changelog: Thu Nov 04 2008 Roberto Bagnara <bagnara@cs.unipr.it> 0.10-2
    bogus date in %changelog: Thu Nov 04 2008 Roberto Bagnara <bagnara@cs.unipr.it> 0.10-1
    Bad exit status from /var/tmp/rpm-tmp.1xeMd9 (%build)
Child return code was: 1
Comment 1 Paulo Andrade 2013-02-04 10:13:54 EST
I have a suggested package and also added extra
information on how to correct some other issues
in #905420
Did not correct the bogus date issues in the
suggested spec, but can do that also (I usually
assume the day number is correct and week day
is wrong on those issues).

*** This bug has been marked as a duplicate of bug 905420 ***

Note You need to log in before you can comment on or make changes to this bug.