Bug 90749 - There is no service manpage
There is no service manpage
Status: CLOSED DUPLICATE of bug 44857
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-13 07:57 EDT by Edward J. Huff
Modified: 2014-03-16 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 14:57:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward J. Huff 2003-05-13 07:57:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
initscripts package includes /sbin/service, but there is no
manpage for this script.


Version-Release number of selected component (if applicable):
initscripts-6.67-1

How reproducible:
Always

Steps to Reproduce:
1.man service
2.
3.
    

Actual Results:  No manual entry for service


Expected Results:  

NAME

service -- run an /etc/init.d script with clean environment

SYNOPSIS

/sbin/service --help | -h | --h | -V | --version 

/sbin/service --status-all

/sbin/service service_name [ command [ options... ] | --full-restart ]

DESCRIPTION

/sbin/service foo cmd

is about the same as running 

/etc/init.d/foo cmd

Or more precisely, it is the same as

cd /etc/init.d/
env -i LANG=$LANG /etc/init.d/foo cmd

which empties the environment except for the LANG variable and runs the 'foo'
script with working directory /etc/init.d/ and specified argument(s).

/sbin/service foo --full-restart

is the same as

cd /etc/init.d/
env -i LANG=$LANG /etc/init.d/foo stop
env -i LANG=$LANG /etc/init.d/foo start

/sbin/service --status-all

invokes all of the scripts in /etc/init.d/ with the 'status' command,
except for those which are obviously not suitable:  scripts
with filenames functions, halt, killall, single, linuxconf, kudzu,
and any scripts with filenames ending in
rpmorig, rpmnew, rpmsave, ~, or .orig.

SEE ALSO

serviceconf(1), ntsysv(8), chkconfig(8)

BUGS

if the OPTIONS environment variable is defined, then service
passes it to the init script ahead of the specified arguments.

The USAGE message should read

Usage: service --help | -h | -V | --version | --status-all | [ service_name [
command [ options... ] | --full-restart ] ]

instead of 

Usage: service < option > | --status-all | [ service_name [ command |
--full-restart ] ]



Additional info:
Comment 1 Edward J. Huff 2003-05-13 08:25:16 EDT
additional bug in script:  should use
env -i LANG="$LANG" ...

BUGS

if the LANG environment variable contains whitespace, then
/sbin/service will malfunction.

# LANG="C echo"
# service ntpd status
/etc/init.d/ntpd status
# LANG=C
# service ntpd status
ntpd (pid 1741) is running...
Comment 2 Bill Nottingham 2005-09-30 14:57:47 EDT

*** This bug has been marked as a duplicate of 44857 ***

Note You need to log in before you can comment on or make changes to this bug.