Bug 907597 - Mouse hover over multi-monitor displays in virt-viewer, hangs system.
Mouse hover over multi-monitor displays in virt-viewer, hangs system.
Status: CLOSED DUPLICATE of bug 856682
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-04 14:37 EST by Bill Sanford
Modified: 2013-02-11 08:54 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-11 08:54:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Logfile of remote-viewer spice://127.0.0.1?port=5900 --spice-debug |& tee /tmp/spice-gtk-bill.log (200.71 KB, text/x-log)
2013-02-04 14:37 EST, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2013-02-04 14:37:19 EST
Created attachment 692972 [details]
Logfile of remote-viewer spice://127.0.0.1?port=5900 --spice-debug |& tee /tmp/spice-gtk-bill.log

Description of problem:
When starting virt-viewer with multiple monitors, hovering the mouse over the virt-viewer View -> Displays while the VM initially starts, will result in the host system hanging. You *must* select the virt-viewer "View -> Displays" when the menu selection only has one display to choose from. When the display choice turns to grey, the whole system is non-responsive.

If I go to the shell and login as root and pkill the virt-viewer, everything is back to normal.

Version-Release number of selected component (if applicable):
RHEL6.4-20130130.0 x86_64 Host
RHEL6.4-20130130.0 x86 Guest

How reproducible:
100%

Steps to Reproduce:
1. Start VM.
2. In a terminal window, type remote-viewer spice://<ipaddress>?port=<ipport> and display the VM that is still booting.
3. In the virt-viewer window, select View and hover over the "Displays" selection.
  
Actual results:
Selection turns grey and system hangs.

Expected results:
Selection turns from Display1 to Display1-4 and system doesn't hang.

Additional info:

This could be a bug in GTK, but assigning to virt-viewer for now.
Comment 1 Tomas Jamrisko 2013-02-11 08:54:03 EST
Sounds like a duplicate of 856682 (same reproducer, same result)

*** This bug has been marked as a duplicate of bug 856682 ***

Note You need to log in before you can comment on or make changes to this bug.