Bug 90760 - Screensavers consuming too much CPU
Screensavers consuming too much CPU
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-13 10:11 EDT by Michael Waite
Modified: 2014-03-16 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-19 14:07:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Waite 2003-05-13 10:11:16 EDT
I did see a few issues still, but none of them are as serious as before. A
couple still chew up a lot of cpu.

-"Maze" does not work, and causes X to chew up to 99.9% of the cpu, but the
difference from before is that the machine is still usable, before it wasn't.
- Decayscreen chews up 80-89% cpu.

Not sure if you care about these other screen saver issues, but since I saw them
I thought I'd mention them even though there is no real impact.

- Crystal will cause any screen savers run after it to not work
- Flag is in the list twice
- GLPlanet is blank on GX260s
- Lisa & Noseguy don't work, just show previous screen saver not moving
- Pipes is just flickers on GX260s

I only tried on Gnome since that is where I saw the issues before.
----------
Action by: mwaite
Issue Registered
----------
Action by: mwaite
Searching Bugzilla now for previous entries.

mwaite assigned to issue for Nortel/CSC.

Category set to: X Windows::Gnome
Status set to: Waiting on Tech
Comment 1 Bill Nottingham 2003-05-18 20:11:05 EDT
Many of the screensavers try to draw as fast as possible... this will cause them
to use CPU. If this is not desired, pick a different one, or, for instance, a
blank screen.

The GX260-related problems sound like graphics card specific issues. 
Comment 2 Jamie Zawinski 2003-06-19 06:08:32 EDT
For the record, *none* of the screensavers try to draw as fast as possible: all
of them (by default) spend enough time in usleep() that they should not be
loading the system significantly.  Plus, xscreensaver runs all of them at a low
priority with nice.

(The unfortunate exception to this is the case of OpenGL hacks running on
systems without GL hardware, in which case, the X server itself tremendously
loads the machine.)

However, it would be normal for a screensaver to consume 80%+ of the CPU -- if
the CPU would otherwise have been *completely idle*.  That is, the saver should
never make the load go above 1.0, though *approaching* 1.0 would be expected.
Comment 3 Bill Nottingham 2003-06-19 14:07:47 EDT
Closing as not a bug; as jwz said things are acting more or less as designed.

Note You need to log in before you can comment on or make changes to this bug.