Bug 907616 - Test case failure: render with multiport cards on ATI Trinity [Radeon HD 7660D] [1002:9901] (Llano)
Summary: Test case failure: render with multiport cards on ATI Trinity [Radeon HD 7660...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-ati
Version: 6.5
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jérôme Glisse
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 960058
TreeView+ depends on / blocked
 
Reported: 2013-02-04 20:25 UTC by Vasiliy Sharapov
Modified: 2013-11-21 10:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Hotplug detection and modesetting was not done automaticly. Consequence: User had to run utility program to force changes when plugging in several monitors. Fix: Updated driver should fix those use case. Result:
Clone Of:
Environment:
Last Closed: 2013-11-21 10:09:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1597 normal SHIPPED_LIVE xorg-x11-drv-ati bug fix and enhancement update 2013-11-21 00:40:13 UTC

Description Vasiliy Sharapov 2013-02-04 20:25:45 UTC
Filed from caserun https://tcms.engineering.redhat.com/run/52543/#caserun_1882956

Version-Release number of selected component (if applicable):
RHEL6.4-20121203.n.0

Steps to Reproduce: 
This case is optional only for those who have multiport graphics (4-port,
8-port or so) in possession. If you have not such card please remove this test
case from your run.

 1. Ensure the 'nomodeset' kernel parameter is not set in your bootloader
    configuration.
 2. Ensure the file /etc/X11/xorg.conf does not exist, or is a valid file that
    uses the valid driver.
 3. Plug as many monitors as graphics outputs you have.
 4. Shut your system down entirely, then start it up again.
 5. Login a X session.
 6. Run gnome-display-properties


 1. Try to change resolution, hit Apply.
 2. Try to rotate different screens, hit Apply.
 3. Try to change possition of screens, hit Apply.



Actual results: 
No hotplugging, monitor arrangement will not refresh until you run xrandr, or open the display preferences, or hit "Detect monitors" in that dialog.

Expected results:
Verify that rendering on all outputs is ok, with no visible corruptions or
crashes.

Comment 3 Jérôme Glisse 2013-05-22 15:25:48 UTC
drm backport should solve that one

Comment 6 Jérôme Glisse 2013-07-16 16:51:51 UTC
Brew build

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=6043812

Comment 8 Tomas Pelka 2013-09-19 12:44:09 UTC
Vasiliy please verify within the Radeon HD 7660 test run.

Thanks
Tom

Comment 11 errata-xmlrpc 2013-11-21 10:09:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1597.html


Note You need to log in before you can comment on or make changes to this bug.