Bug 907676 - GRUB cannot be installed to a partition
GRUB cannot be installed to a partition
Status: CLOSED DUPLICATE of bug 872826
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-04 18:55 EST by Daniel Laczi
Modified: 2013-02-05 10:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 10:26:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Laczi 2013-02-04 18:55:57 EST
Description of problem:
There is no option to install GRUB2 to a partition in Fedora 18. GRUB2's installation can be unchecked or GRUB2 can be installed to the MBR, but there is no option to install it to a partition. If you already have another bootloader in your MBR, this is actually sad.

Version-Release number of selected component (if applicable):
Anaconda shipped with Fedora 18 DVD 

How reproducible:
Start the installation of Fedora 18 with the DVD. Configure the destination and try to find an option to install GRUB2 to a partition.
  
Actual results:
I was not able to install GRUB2 to a partition during the installation routine, so I did not install it with anaconda. Later on I installed it via a Live CD and using chroot. Fedora 18 did boot fine, but while I was configuring the new system I discovered that anaconda also missed to generate /etc/default/grub.

Expected results:
There should be an option, that allows you to install GRUB to a partition.

Additional info:
If you do not install GRUB, anaconda does not generate /etc/default/grub.
Comment 1 Chris Lumens 2013-02-05 10:26:09 EST

*** This bug has been marked as a duplicate of bug 872826 ***

Note You need to log in before you can comment on or make changes to this bug.