Bug 907710
| Summary: | Replication error messages in the DS error logs | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 7 | Reporter: | Sankar Ramalingam <sramling> |
| Component: | 389-ds-base | Assignee: | Rich Megginson <rmeggins> |
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Sankar Ramalingam <sramling> |
| Severity: | medium | Docs Contact: | |
| Priority: | medium | ||
| Version: | 7.0 | CC: | jgalipea, mreynolds, nhosoi, nkinder |
| Target Milestone: | rc | ||
| Target Release: | --- | ||
| Hardware: | All | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | 389-ds-base-1.3.1.2-1.el7 | Doc Type: | Bug Fix |
| Doc Text: |
Cause: Normal replication operation, where the DNA plugin in involved.
Consequence: Vague warning messages can be generated, even though replication is working.
Fix: Moved some error messages to only be displayed when using verbose replication logging. Then improved the detail/meaning of other error messages.
Result: Error logging has less false alarms, and other errors have more detail.
|
Story Points: | --- |
| Clone Of: | Environment: | ||
| Last Closed: | 2014-06-13 11:18:03 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Description
Sankar Ramalingam
2013-02-05 05:01:44 UTC
This request was not resolved in time for the current release. Red Hat invites you to ask your support representative to propose this request, if still desired, for consideration in the next release of Red Hat Enterprise Linux. Upstream ticket: https://fedorahosted.org/389/ticket/587 moving all ON_QA bugs to MODIFIED in order to add them to the errata (can't add bugs in the ON_QA state to an errata). When the errata is created, the bugs should be automatically moved back to ON_QA. I encountered similar errors with the latest 389-ds-base on RHEL7. Hence, reopening the bug. I configured fourwayMMR with DNA plugin.
[08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin - ruv_compare_ruv: RUV [changelog max RUV] does not contain element [{replica 1232 ldap://ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com:1289} 527ce961000004d00000 527ce961000e04d00000] which is present in RUV [database RUV]
[08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin - replica_check_for_data_reload: Warning: for replica dc=passsync,dc=com there were some differences between the changelog max RUV and the database RUV. If there are obsolete elements in the database RUV, you should remove them using the CLEANALLRUV task. If they are not obsolete, you should check their status to see why there are no changes from those servers in the changelog.
[08/Nov/2013:08:48:39 -0500] slapi_ldap_bind - Error: could not send bind request for id [cn=SyncManager,cn=config] authentication mechanism [SIMPLE]: error -1 (Can't contact LDAP server), system error -5987 (Invalid function argument.), network error 107 (Transport endpoint is not connected, host "ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com")
[08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin - agmt="cn=1289_to_1616_on_ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com" (ibm-x3650m4-01-vm-14:1616): Replication bind with SIMPLE auth failed: LDAP error -1 (Can't contact LDAP server) ()
(In reply to Sankar Ramalingam from comment #7) > I encountered similar errors with the latest 389-ds-base on RHEL7. Hence, > reopening the bug. I configured fourwayMMR with DNA plugin. > > [08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin - ruv_compare_ruv: RUV > [changelog max RUV] does not contain element [{replica 1232 > ldap://ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com:1289} > 527ce961000004d00000 527ce961000e04d00000] which is present in RUV [database > RUV] > [08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin - > replica_check_for_data_reload: Warning: for replica dc=passsync,dc=com there > were some differences between the changelog max RUV and the database RUV. > If there are obsolete elements in the database RUV, you should remove them > using the CLEANALLRUV task. If they are not obsolete, you should check > their status to see why there are no changes from those servers in the > changelog. > [08/Nov/2013:08:48:39 -0500] slapi_ldap_bind - Error: could not send bind > request for id [cn=SyncManager,cn=config] authentication mechanism [SIMPLE]: > error -1 (Can't contact LDAP server), system error -5987 (Invalid function > argument.), network error 107 (Transport endpoint is not connected, host > "ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com") > [08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin - > agmt="cn=1289_to_1616_on_ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com" > (ibm-x3650m4-01-vm-14:1616): Replication bind with SIMPLE auth failed: LDAP > error -1 (Can't contact LDAP server) () These errors have nothing to do with the original issue. There is nothing to do with DNA in regards to these errors. It looks like the setup is not correct, or the environment was not cleaned up from a previously test(winsync testing?), regardless this has nothing to do with the DNA plugin. Just gone through the patch added by Mark and realized that the original issue was about the replication throws an error message as "unknown" error. The fix is already provided by Mark for that particular issue. Now, it displays "system error -5987 (Invalid function argument.). So, marking the bug as Verified. This request was resolved in Red Hat Enterprise Linux 7.0. Contact your manager or support representative in case you have further questions about the request. |