Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 907710

Summary: Replication error messages in the DS error logs
Product: Red Hat Enterprise Linux 7 Reporter: Sankar Ramalingam <sramling>
Component: 389-ds-baseAssignee: Rich Megginson <rmeggins>
Status: CLOSED CURRENTRELEASE QA Contact: Sankar Ramalingam <sramling>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: jgalipea, mreynolds, nhosoi, nkinder
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 389-ds-base-1.3.1.2-1.el7 Doc Type: Bug Fix
Doc Text:
Cause: Normal replication operation, where the DNA plugin in involved. Consequence: Vague warning messages can be generated, even though replication is working. Fix: Moved some error messages to only be displayed when using verbose replication logging. Then improved the detail/meaning of other error messages. Result: Error logging has less false alarms, and other errors have more detail.
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-13 11:18:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Sankar Ramalingam 2013-02-05 05:01:44 UTC
Description of problem: When replication is in place, I see lot of error messages in the error logs which is very confusing. I observe these error messages even though the replication works just fine.

Version-Release number of selected component (if applicable): 389-ds-base-1.2.11

How reproducible: Consistent

Steps to Reproduce:
1. Run fourwaymmr or DNA acceptance tests from tet.
2. Make sure there is no cleanup tests and uninstall tests are called.
3. When test execution finished, take a look at the error logs.
4. There are few common error messages in the error logs even though all tests succeeded.
  
Actual results:

[04/Feb/2013:23:02:04 -0500] NSMMReplicationPlugin - agmt="cn=S2 Agreement" (dell-pe2800-01:24204): Replica has a different generation ID than the local data.

[04/Feb/2013:23:13:01 -0500] slapi_ldap_bind - Error: could not send bind request for id [cn=Replication Manager,cn=config] mech [SIMPLE]: error -1 (Can't contact LDAP server) 0 (unknown) 107 (Transport endpoint is not connected)
[04/Feb/2013:23:13:01 -0500] dna-plugin - dna_request_range: Error binding  to replica server dell-pe2800-01.rhts.eng.bos.redhat.com:24204. [error -1]
[04/Feb/2013:23:13:01 -0500] dna-plugin - dna_pre_op: Passed threshold of 5 remaining values for range cn=account uids,cn=distributed numeric assignment plugin,cn=plugins,cn=config. (2 values remain)



[04/Feb/2013:23:12:23 -0500] NSMMReplicationPlugin - agmt="cn=S1 Agreement" (dell-pe2800-01:24202): Warning: unable to receive endReplication extended operation response (Can't contact LDAP server)
[04/Feb/2013:23:12:23 -0500] slapi_ldap_bind - Error: could not send bind request for id [cn=Replication Manager,cn=config] mech [SIMPLE]: error -1 (Can't contact LDAP server) 0 (unknown) 107 (Transport endpoint is not connected)


Expected results:

The error/warning mesages should be more meaningful and user friendly.

Comment 2 RHEL Program Management 2013-02-09 06:47:10 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 Nathan Kinder 2013-02-18 16:27:10 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/587

Comment 5 Rich Megginson 2013-10-01 23:26:12 UTC
moving all ON_QA bugs to MODIFIED in order to add them to the errata (can't add bugs in the ON_QA state to an errata).  When the errata is created, the bugs should be automatically moved back to ON_QA.

Comment 7 Sankar Ramalingam 2013-11-08 13:53:31 UTC
I encountered similar errors with the latest 389-ds-base on RHEL7. Hence, reopening the bug. I configured fourwayMMR with DNA plugin.

[08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin - ruv_compare_ruv: RUV [changelog max RUV] does not contain element [{replica 1232 ldap://ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com:1289} 527ce961000004d00000 527ce961000e04d00000] which is present in RUV [database RUV]
[08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin - replica_check_for_data_reload: Warning: for replica dc=passsync,dc=com there were some differences between the changelog max RUV and the database RUV.  If there are obsolete elements in the database RUV, you should remove them using the CLEANALLRUV task.  If they are not obsolete, you should check their status to see why there are no changes from those servers in the changelog.
[08/Nov/2013:08:48:39 -0500] slapi_ldap_bind - Error: could not send bind request for id [cn=SyncManager,cn=config] authentication mechanism [SIMPLE]: error -1 (Can't contact LDAP server), system error -5987 (Invalid function argument.), network error 107 (Transport endpoint is not connected, host "ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com")
[08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin - agmt="cn=1289_to_1616_on_ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com" (ibm-x3650m4-01-vm-14:1616): Replication bind with SIMPLE auth failed: LDAP error -1 (Can't contact LDAP server) ()

Comment 8 mreynolds 2013-11-08 14:10:23 UTC
(In reply to Sankar Ramalingam from comment #7)
> I encountered similar errors with the latest 389-ds-base on RHEL7. Hence,
> reopening the bug. I configured fourwayMMR with DNA plugin.
> 
> [08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin - ruv_compare_ruv: RUV
> [changelog max RUV] does not contain element [{replica 1232
> ldap://ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com:1289}
> 527ce961000004d00000 527ce961000e04d00000] which is present in RUV [database
> RUV]
> [08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin -
> replica_check_for_data_reload: Warning: for replica dc=passsync,dc=com there
> were some differences between the changelog max RUV and the database RUV. 
> If there are obsolete elements in the database RUV, you should remove them
> using the CLEANALLRUV task.  If they are not obsolete, you should check
> their status to see why there are no changes from those servers in the
> changelog.
> [08/Nov/2013:08:48:39 -0500] slapi_ldap_bind - Error: could not send bind
> request for id [cn=SyncManager,cn=config] authentication mechanism [SIMPLE]:
> error -1 (Can't contact LDAP server), system error -5987 (Invalid function
> argument.), network error 107 (Transport endpoint is not connected, host
> "ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com")
> [08/Nov/2013:08:48:39 -0500] NSMMReplicationPlugin -
> agmt="cn=1289_to_1616_on_ibm-x3650m4-01-vm-14.lab.eng.bos.redhat.com"
> (ibm-x3650m4-01-vm-14:1616): Replication bind with SIMPLE auth failed: LDAP
> error -1 (Can't contact LDAP server) ()

These errors have nothing to do with the original issue.  There is nothing to do with DNA in regards to these errors.  It looks like the setup is not correct, or the environment was not cleaned up from a previously test(winsync testing?), regardless this has nothing to do with the DNA plugin.

Comment 9 Sankar Ramalingam 2013-11-11 16:32:24 UTC
Just gone through the patch added by Mark and realized that the original issue was about the replication throws an error message as "unknown" error. The fix is already provided by Mark for that particular issue. Now, it displays "system error -5987 (Invalid function argument.). So, marking the bug as Verified.

Comment 10 Ludek Smid 2014-06-13 11:18:03 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.