Bug 907749 - PLEASE remove util-linux-2.22.2-3 from updates-testing
Summary: PLEASE remove util-linux-2.22.2-3 from updates-testing
Keywords:
Status: CLOSED DUPLICATE of bug 887763
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-05 07:49 UTC by Harald Reindl
Modified: 2013-02-05 15:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-05 15:30:06 UTC


Attachments (Terms of Use)

Description Harald Reindl 2013-02-05 07:49:49 UTC
look at  https://bugzilla.redhat.com/show_bug.cgi?id=887763#c13
util-linux-2.22.2-3.fc18.x86_64 kills output of "mount" completly
which leads to break also "df" and who knows what else

Comment 1 Harald Reindl 2013-02-05 12:14:49 UTC
or if you would not braindead mangle around with /etc/mtab in the SPEC-file there would no need for reboot or manually re-create the symlink after a yum update - jesus christ this is a SYMLINK and why in the world would a symlink to /proc/mount have to be touched from anything but the kernel or systemd?

https://bugzilla.redhat.com/show_bug.cgi?id=887763#c20

Comment 2 Karel Zak 2013-02-05 15:13:50 UTC
Well, there is 

  %post
  rm -f /etc/mtab
  ln -s /proc/mounts /etc/mtab

in the spec file, maybe it should be improved to use 

  %post
  if [ ! -L /etc/mtab ]; then
    rm -f /etc/mtab
    ln -s /proc/mounts /etc/mtab
  fi
  
but it still does not explain why _you_ have the problem with update and on all others systems it works.

Comment 3 Karel Zak 2013-02-05 15:30:06 UTC
Let's continue at bug #887763.

*** This bug has been marked as a duplicate of bug 887763 ***


Note You need to log in before you can comment on or make changes to this bug.