Bug 907776 - [User Portal] Run Once - VNC - console is still SPICE
[User Portal] Run Once - VNC - console is still SPICE
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.2.0
Assigned To: Arik
Jiri Belka
virt
: Regression, Reopened, TestBlocker
Depends On:
Blocks: 915537 922807 948448
  Show dependency treegraph
 
Reported: 2013-02-05 04:05 EST by Jiri Belka
Modified: 2013-06-11 04:32 EDT (History)
11 users (show)

See Also:
Fixed In Version: sf13.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log, vdsm.log (19.98 KB, application/x-tar)
2013-02-05 04:05 EST, Jiri Belka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11790 None None None Never
oVirt gerrit 12748 None None None Never
oVirt gerrit 13693 None None None Never

  None (edit)
Description Jiri Belka 2013-02-05 04:05:39 EST
Created attachment 693285 [details]
engine.log, vdsm.log

Description of problem:
[User Portal] Run Once - VNC - console is still SPICE. Run Once dialog from Administration Portal makes console VNC, so this issue is in User Portal only.

Version-Release number of selected component (if applicable):
sf5

How reproducible:
100%

Steps to Reproduce:
1. a VM in User Portal
2. Run Once -> console VNC
3. dumpxml|ps aux for kvm args|open console
  
Actual results:
it is not VNC type but still SPICE

Expected results:
VNC type

Additional info:
in Administration Portal this works OK
Comment 1 Jiri Belka 2013-02-05 04:16:02 EST
ic159 (3.0  ok),  si26.1 (3.1.2 - not ok)
Comment 8 Jiri Belka 2013-03-05 05:10:04 EST
Couple of comments (tested from RHEL6.4 FF17):

* after Run Once -> vnc for console - args for qemu-kvm contain now correctly '-vnc $ip:$port'
* i cannot open in any way vnc console in User Portal (in Extended view the button is gray, in Basic view there is _NO_ 'Double click for console' while hovering over the VM's icon
* in Basic view, Console: contains SPICE (this is nonsense in this context)
* in Extended view, I cannot open console options in any way as button is gray

Thus unable to use VNC console in UP.
Comment 10 Jiri Belka 2013-03-12 07:46:11 EDT
ok, sf10.
Comment 11 Arik 2013-04-02 08:32:08 EDT
switch it back to "assigned" as I discovered that the fix is no longer valid because of other changes that were made since it was marged. the fix should be merged and tested again.
Comment 13 Jiri Belka 2013-04-15 03:56:00 EDT
sf13.1 - looks good, although I get mime file instead of popup but that's another BZ i think.
Comment 14 Itamar Heim 2013-06-11 04:30:02 EDT
3.2 has been released
Comment 15 Itamar Heim 2013-06-11 04:30:02 EDT
3.2 has been released
Comment 16 Itamar Heim 2013-06-11 04:32:20 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.