This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 907800 - tcl-snack included non-free and license unclear files
tcl-snack included non-free and license unclear files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tcl-snack (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2013-02-05 05:21 EST by mejiko
Modified: 2013-02-13 16:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 16:39:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 688020 None None None Never

  None (edit)
Description mejiko 2013-02-05 05:21:12 EST
Hello.

tcl-snack included non-free files.


Files:

generic/Soundfile.c
generic/ffa.c
generic/shape.c
generic/snackDecls.h
generic/snackStubInit.c
generic/snackStubLib.c
generic/SphereFile.c
mac/snack.mcp.sit.hqx 


generic/ffa.c license statement is "All rights reserved". (not permitted distribute)

generic/snackDecls.h, generic/snackStubInit.c and generic/snackStubLib.c license is "see license.terms". but "license.terms" not find. (license statement is unclear)

mac/snack.mcp.sit.hqx is binary.

Question: Where is source code ?

other non-free files license is unknown. (license statement is unknown)

Its non-free.


Seggests:

1. Remove non-free files and rebuild.

2. Replace fedora free (Fedora acceptable licensed) files.

3. Remove fedora repos.

Thanks.


Reference:

https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing
Comment 1 mejiko 2013-02-05 05:22:05 EST
Blocking FE-Legal, This is license problem.
Comment 2 Tom "spot" Callaway 2013-02-12 16:01:19 EST
So, the files under "license.terms" are referring to the master Tcl/Tk license (originally written by Scriptics). This is a semi-common practice for old tcl/tk code to do. The license text for Tcl/Tk is here:
http://www.tcl.tk/software/tcltk/license.html

Fedora calls that license "TCL". It is Free and GPL compatible.

generic/Soundfile.c doesn't exist in the Fedora package. (generic/jkSoundFile.c does, but it is clearly GPLv2+)

generic/shape.c is marked as a "contribution to the Snack Sound Library", it is safe to assume it is under the same license terms as the rest of Snack (GPLv2+).

generic/SphereFile.c is copyright of Claude Barras and Kare Sjolander, the latter is the main copyright holder for the rest of Snack. It is safe to assume it is under the same license terms as the rest of Snack (GPLv2+).

mac/snack.mcp.sit.hqx has been removed from the source tarball in rawhide. I don't know if it is free or not because I can't get it to decompress and open.

I've emailed Roger Lindell to confirm the license on generic/ffa.c. I strongly suspect it is GPLv2+, but I would like to confirm that, since there is no other obvious indicator (although, Roger did work at KTH alongside Kare, and he is listed in the README as a contributor). I'll leave this open until I hear from him.
Comment 3 Tom "spot" Callaway 2013-02-13 16:39:50 EST
Roger Lindell replied to me and confirmed his code (generic/ffa.c) is GPL. I have included a copy of that correspondence in the package

Note You need to log in before you can comment on or make changes to this bug.