Bug 907820 - (CVE-2013-0256) CVE-2013-0256 rubygem-rdoc: Cross-site scripting in the documentation created by Darkfish Rdoc HTML generator / template
CVE-2013-0256 rubygem-rdoc: Cross-site scripting in the documentation created...
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20130206,repor...
: Security
Depends On: 907828 907833 907835 908358 908890 909340 913819 915192 928603 928604 928606 928615 995674
Blocks: 907842 917158 925830 928635
  Show dependency treegraph
 
Reported: 2013-02-05 05:56 EST by Jan Lieskovsky
Modified: 2016-03-04 07:21 EST (History)
28 users (show)

See Also:
Fixed In Version: RDoc 3.9.5, RDoc 3.12.1, RDoc 4.0.0.rc.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-03 01:19:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Lieskovsky 2013-02-05 05:56:14 EST
A cross-site scripting (XSS) flaw was found in the way Darkfish Rdoc HTML generator / template of RDoc, HTML and command-line documentation producing tool for Ruby, performed sanitization of certain values when creating Rdoc documentation. When Ruby on Rails application exposed its documentation via network, a remote attacker could provide a specially-crafted URL that, when opened would lead to arbitrary web script or HTML code execution in the context of (particular Ruby on Rails application) user's session.

This issue affects RDoc versions 2.3.0 to 3.12.
Comment 2 Jan Lieskovsky 2013-02-05 06:01:24 EST
This issue affects the versions of the rubygem-rdoc package, as shipped with Red Hat OpenShift Enterprise, Red Hat Subscription Asset Manager, Red Hat CloudForms System Engine, and Red Hat CloudForms Cloud Engine.

--

This issue affects the versions of the rubygem-rdoc package, as shipped with Fedora release of 16, 17, and 18.
Comment 4 Jan Lieskovsky 2013-02-05 06:06:31 EST
Acknowledgements:

Red Hat would like to thank Eric Hodel of RDoc upstream for reporting this issue. Upstream acknowledges Evgeny Ermakov as the original issue reporter.
Comment 12 Jan Lieskovsky 2013-02-06 09:07:07 EST
External References:


http://www.ruby-lang.org/en/news/2013/02/06/rdoc-xss-cve-2013-0256/
Comment 13 Jan Lieskovsky 2013-02-06 09:08:59 EST
Created rubygem-rdoc tracking bugs for this issue

Affects: fedora-all [bug 908358]
Comment 14 Jan Lieskovsky 2013-02-06 09:12:19 EST
Relevant upstream patch:
  https://github.com/rdoc/rdoc/commit/ffa87887ee0517793df7541629a470e331f9fe60
Comment 15 Jan Lieskovsky 2013-02-07 05:33:22 EST
RDoc 3.9.5, 3.12.1, and 4.0.0.rc.2 announcement:
  http://blog.segment7.net/2013/02/06/rdoc-xss-vulnerability-cve-2013-0256-releases-3-9-5-3-12-1-4-0-0-rc-2
Comment 18 errata-xmlrpc 2013-02-21 14:05:58 EST
This issue has been addressed in following products:

  CloudForms for RHEL 6

Via RHSA-2013:0548 https://rhn.redhat.com/errata/RHSA-2013-0548.html
Comment 20 errata-xmlrpc 2013-03-26 15:17:32 EDT
This issue has been addressed in following products:

  Red Hat Subscription Asset Manager 1.2

Via RHSA-2013:0686 https://rhn.redhat.com/errata/RHSA-2013-0686.html
Comment 22 errata-xmlrpc 2013-04-02 16:06:53 EDT
This issue has been addressed in following products:

  RHEL 6 Version of OpenShift Enterprise

Via RHSA-2013:0701 https://rhn.redhat.com/errata/RHSA-2013-0701.html
Comment 23 errata-xmlrpc 2013-04-09 14:13:50 EDT
This issue has been addressed in following products:

  RHEL 6 Version of OpenShift Enterprise

Via RHSA-2013:0728 https://rhn.redhat.com/errata/RHSA-2013-0728.html
Comment 24 Fedora Update System 2013-05-07 14:25:39 EDT
rubygem-rdoc-3.12-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2013-05-07 14:36:36 EDT
rubygem-rdoc-3.12-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Kurt Seifried 2013-07-26 02:16:28 EDT
The Red Hat Security Response Team has rated this issue as having moderate security impact in CloudForms 1.1. This issue is not currently planned to be addressed in future updates.

Note You need to log in before you can comment on or make changes to this bug.