Bug 907837 - man useradd is incorrect (again)
man useradd is incorrect (again)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.3
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Peter Schiffer
Iveta Wiedermann
: ManPageChange, Patch
Depends On:
Blocks: 1011230
  Show dependency treegraph
 
Reported: 2013-02-05 06:15 EST by Ken Sugawara
Modified: 2013-11-21 17:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: incorrect description of "-u, --uid UID" option on useradd(8) man page Consequence: incorrect documentation Fix: fix description of "-u, --uid UID" option on useradd(8) man page Result: correct documentation
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:55:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
useradd.8.patch (868 bytes, patch)
2013-09-19 06:48 EDT, Peter Schiffer
no flags Details | Diff

  None (edit)
Description Ken Sugawara 2013-02-05 06:15:53 EST
Description of problem:
useradd(1) states 


Version-Release number of selected component (if applicable):
shadow-utils-4.1.4.2-13.el6

How reproducible:
Always


Steps to Reproduce:
1. Fresh install RHEL 6
2. useradd foo
3. Observe that foo's UID value is 500.
4. man useradd
   Observe the section describing the -u option.
 
Actual results:
       -u, --uid UID
           The numerical value of the user?s ID. This value must be unique,
           unless the -o option is used. The value must be non-negative. The
           default is to use the smallest ID value greater than 999 and
           greater than every other user. Values between 0 and 999 are
           typically reserved for system accounts.


Expected results:
       -u, --uid UID
           The numerical value of the user?s ID. This value must be unique,
           unless the -o option is used. The value must be non-negative. The
           default is to use the smallest ID value greater than 499 and
           greater than every other user. Values between 0 and 499 are
           typically reserved for system accounts.


Additional info:
I see that /etc/login.defs is patched so that UID_MIN and GID_MIN are both 500 but the man page does not reflect that change. If this is an intended behavior, the man page should be fixed as well.
Comment 2 Peter Schiffer 2013-09-19 06:48:24 EDT
Created attachment 799833 [details]
useradd.8.patch
Comment 10 errata-xmlrpc 2013-11-21 17:55:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1695.html

Note You need to log in before you can comment on or make changes to this bug.