Bug 90788 - klipper fails to expand %s to the clipboard contents after RHSA-2003:002 is applied
klipper fails to expand %s to the clipboard contents after RHSA-2003:002 is a...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-13 15:25 EDT by Need Real Name
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-14 12:16:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-05-13 15:25:36 EDT
Description of problem:

After applying the updates for RH8 specified in errata RHSA-2003:002, klipper
fails to expand %s to the clipboard contents. 

Version-Release number of selected component (if applicable):

kdebase-3.0.5a-4

How reproducible:

100%, this did not occur prior to the update of kdebase that occured with
RHSA-2003:002

Steps to Reproduce:
1. Setup a klipper action that looks like '^http[s]?:\/\/' which calls 'mozilla
"%s"'
2. Highlight a URL and choose "Open with Mozilla"
3. mozilla will attempt to open the literal '%s' as a URL.
    
Actual results:

The literal '%s' is opened as the URL in mozilla

Expected results:

klipper should substitute the url for %s and mozilla should open that.

Additional info:

Prior to the update of kdebase this action worked without problems. Note this
fails in the same way with other actions that open other apps. It is not limited
to mozilla.

I've marked this as severity high since it serious impacts the usefulness of KDE
Comment 1 Ngo Than 2003-05-14 12:16:27 EDT
hmm i think this bug was in RHL 8.0 too. It's not fixed in this errata.

I have fixed it in kde-3.1.2, which will be available in rawhide soon.

To fix this problem you have to change the lines in /usr/share/config/klipperrc

Commandline=ps x |grep -q '[m]ozilla' && mozilla -remote "openURL(%s,
new-window)" || mozilla %s

to

Commandline=ps x |grep -q '[m]ozilla' && mozilla -remote "openURL(`echo %s`,
new-window)" || mozilla %s

and 
Commandline=mozilla -remote "openURL(%s, new-window)"
to
Commandline=mozilla -remote "openURL(`echo %s`, new-window)"
Comment 2 danf 2003-05-26 16:54:48 EDT
This problem also affects the security update for Red Hat 7.2 (kdebase-2.2.2-7).
Will an updated package for KDE 2.2 be made available as well?

Note You need to log in before you can comment on or make changes to this bug.