Bug 907892 (CVE-2013-0255) - CVE-2013-0255 postgresql: array indexing error in enum_recv()
Summary: CVE-2013-0255 postgresql: array indexing error in enum_recv()
Status: NEW
Alias: CVE-2013-0255
Product: Security Response
Classification: Other
Component: vulnerability   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20130207,repor...
Keywords: Security
Depends On: 908722 1017833 1017835 1017836 1017837
Blocks: 907896
TreeView+ depends on / blocked
 
Reported: 2013-02-05 13:33 UTC by Jan Lieskovsky
Modified: 2018-12-03 18:15 UTC (History)
4 users (show)

Fixed In Version: PostgreSQL 9.2.3, PostgreSQL 9.1.8, PostgreSQL 9.0.12, PostgreSQL 8.4.16, PostgreSQL 8.3.23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2013:1475 normal SHIPPED_LIVE Moderate: postgresql and postgresql84 security update 2013-10-29 23:43:31 UTC

Description Jan Lieskovsky 2013-02-05 13:33:34 UTC
An array index error, leading to out of heap-based buffer bounds read flaw was found in the way PostgreSQL, an advanced Object-Relational database management system (DBMS), performed retrieval of textual form of error message representation when processing certain enumeration types. An unprivileged database user could issue a specially-crafted SQL query that, when processed by the server component of the PostgreSQL service, would lead to denial of service (daemon crash) or disclosure (of certain portions of) server memory.

Comment 2 Jan Lieskovsky 2013-02-05 13:39:13 UTC
This issue did NOT affect the versions of the postgresql package, as shipped with Red Hat Enterprise Linux 5.

--

This issue affects the version of the postgresql84 package, as shipped with Red Hat Enterprise Linux 5 and the version of postgresql package, as shipped with Red Hat Enterprise Linux 6.

--

This issue affects the versions of the postgresql package, as shipped with Fedora release of 16, 17, and 18.

Comment 3 Jan Lieskovsky 2013-02-05 13:41:04 UTC
Acknowledgements:

Red Hat would like to thank the PostgreSQL project for reporting this issue. Upstream acknowledges Sumit Soni via Secunia SVCRP as the original issue reporter.

Comment 7 Jan Lieskovsky 2013-02-07 11:35:35 UTC
Public via:
  http://www.postgresql.org/support/security/

Comment 8 Jan Lieskovsky 2013-02-07 11:36:21 UTC
Created postgresql tracking bugs for this issue

Affects: fedora-all [bug 908722]

Comment 9 Jan Lieskovsky 2013-02-07 11:41:16 UTC
Statement:

This issue did not affect the version of postgresql, as shipped with Red Hat Enterprise Linux 5. This issue affects the version of postgresql84, as shipped with Red Hat Enterprise Linux 5 and the version of postgresql, as shipped with Red Hat Enterprise Linux 6. Red Hat Security Response Team has rated this issue as having moderate security impact. A future update might address this flaw. For additional information, refer to the Issue Severity Classification: https://access.redhat.com/security/updates/classification/.

Comment 11 Fedora Update System 2013-02-11 04:53:41 UTC
postgresql-9.2.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-02-17 03:29:56 UTC
postgresql-9.1.8-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 errata-xmlrpc 2013-10-29 19:44:45 UTC
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6
  Red Hat Enterprise Linux 5

Via RHSA-2013:1475 https://rhn.redhat.com/errata/RHSA-2013-1475.html


Note You need to log in before you can comment on or make changes to this bug.