Bug 907939 - GtkEntryCompletion for GtkCombobox's GtkEntry doesn't render correctly if loaded from the glade file
GtkEntryCompletion for GtkCombobox's GtkEntry doesn't render correctly if loa...
Status: CLOSED DUPLICATE of bug 907946
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 875432
  Show dependency treegraph
 
Reported: 2013-02-05 10:04 EST by Vratislav Podzimek
Modified: 2013-04-09 08:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-09 08:26:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer that needs the combobox.glade file in the same directory (577 bytes, text/x-python)
2013-02-05 10:04 EST, Vratislav Podzimek
no flags Details

  None (edit)
Description Vratislav Podzimek 2013-02-05 10:04:56 EST
Created attachment 693402 [details]
reproducer that needs the combobox.glade file in the same directory

Description of problem:
When using GtkCombobox with GtkEntry and GtkEntryCompletion for it loaded from the .glade file, the completion is not rendered correctly (doesn't appear).


Version-Release number of selected component (if applicable):
gtk3-3.6.2-1
glade3-3.8.3-1

works with:
gtk3-3.4.4-1.fc17.x86_64
glade-3.14.1-1.fc18.x86_64

How reproducible:
100 %

Steps to Reproduce:
1. run the attached reproducer (combobox_test.py)
2. try to type 'f' to the upper combobox's entry
  
Actual results:
only some "shadow" appears

Expected results:
completion appears

Additional info:
combobox_noglade.py (attached) works as expected (try to type 'a')
Comment 1 Vratislav Podzimek 2013-04-09 08:26:29 EDT

*** This bug has been marked as a duplicate of bug 907946 ***

Note You need to log in before you can comment on or make changes to this bug.