Bug 907992 - Fatal bugs in translations
Fatal bugs in translations
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Katello Bug Bin
sthirugn@redhat.com
: Triaged
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-02-05 10:44 EST by Miroslav Suchý
Modified: 2013-10-01 07:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:05:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (6.04 KB, patch)
2013-02-05 10:46 EST, Miroslav Suchý
no flags Details | Diff
po files test output.log (1.00 KB, application/x-shellscript)
2013-09-10 16:09 EDT, sthirugn@redhat.com
no flags Details

  None (edit)
Description Miroslav Suchý 2013-02-05 10:44:01 EST
There are several problems in translations which will result in traceback under given localization:

Since localization tool reformat the string I highlight the problematic parts:

 msgid "Unsuccessfully forgot option [ %s ]"
-msgstr "Opção "
+msgstr "Sem sucesso esqueci opção [ %s ]"

^ missing %s

 msgid "Cannot find permission [ %s ] for user role [ %s ]"
-msgstr "사용자 역할 [ %s ]의 권한을 찾을 수 없음 "
+msgstr "사용자 역할 [ %s ]의 권한을 [ %s ] 찾을 수 없음 "


^ missing %s

 msgid "name of the parameter, %s must follow"
-msgstr "参数名,% 必须跟着"
+msgstr "参数名,%s 必须跟着"

^ missign s after percent char

 msgid "Repo List for Product %s in Org %s "
-msgstr "机构 %s 中产品的库列表"
+msgstr "机构 %s 中产品的库列表 %s"

^ missign s after percent char
Comment 1 Miroslav Suchý 2013-02-05 10:46:04 EST
Created attachment 693443 [details]
Patch
Comment 2 Miroslav Suchý 2013-02-05 10:48:08 EST
Katello upstream is not affected, this is related only to SAM.
Comment 3 Miroslav Suchý 2013-02-05 11:09:52 EST
Since this is used in python code, it will raise traceback when used:

[16:51] <msuchy> >>> "foo %s" % 1
[16:51] <msuchy> 'foo 1'
[16:51] <msuchy> >>> "foo" % 1
[16:51] <msuchy> Traceback (most recent call last):
[16:51] <msuchy>   File "<stdin>", line 1, in <module>
[16:51] <msuchy> TypeError: not all arguments converted during string formatting
[16:52] <msuchy> >>> "foo %s %s" % 1
[16:52] <msuchy> Traceback (most recent call last):
[16:52] <msuchy>   File "<stdin>", line 1, in <module>
[16:52] <msuchy> TypeError: not enough arguments for format string
Comment 4 Bryan Kearney 2013-08-28 12:57:37 EDT
1.4.3-11-sat has the latest strings, so these bugs shuld be fixed.
Comment 6 Miroslav Suchý 2013-09-10 02:22:34 EDT
> msgid "Repo List for Product %s in Org %s "
I would guess that this will be used when you use katello-cli to list repositories for some products.
Comment 9 Bryan Kearney 2013-09-10 09:08:37 EDT
The make scripts now check for this, and therefore there should be no failed messages. There may be incomplete translations, but there should not be failed messages now.
Comment 10 sthirugn@redhat.com 2013-09-10 16:08:47 EDT
VERIFIED.  I did not see any traceback now.  Attached the output of the .po files test.

Version Tested:
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-10.el6sat.noarch
* katello-cli-common-1.4.3-10.el6sat.noarch
* katello-common-1.4.3-12.el6sam_splice.noarch
* katello-configure-1.4.4-4.el6sat.noarch
* katello-glue-candlepin-1.4.3-12.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-12.el6sam_splice.noarch
* katello-headpin-1.4.3-12.el6sam_splice.noarch
* katello-headpin-all-1.4.3-12.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.34-1.el6sam.noarch
* thumbslug-selinux-0.0.34-1.el6sam.noarch
Comment 11 sthirugn@redhat.com 2013-09-10 16:09:19 EDT
Created attachment 796127 [details]
po files test output.log
Comment 13 errata-xmlrpc 2013-10-01 07:05:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.