Bug 908014 - rhncfg-actions should require new version of rhn-client-tools
rhncfg-actions should require new version of rhn-client-tools
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
550
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Herr
Dimitar Yordanov
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-02-05 11:38 EST by Stephen Herr
Modified: 2013-10-03 08:13 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhncfg-5.10.55-3-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 908011
Environment:
Last Closed: 2013-10-01 15:59:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2013-02-05 11:38:51 EST
+++ This bug was initially created as a clone of Bug #908011 +++

Modern versions of rhncfg-actions can call the getServerlURL() method in the rhn-client-tools up2date_client/config.py. That method does not exist prior to rhn-client-tools-1.3.7-1, so rhncfg-actions should require that version or newer, not just any version.

--- Additional comment from Stephen Herr on 2013-02-05 11:36:48 EST ---

It's not just rhncfg-actions, there's some common code that can call that function too, so I made the dependency be on rhncfg.

Committed to Spacewalk master: e0eb1fbccebf85aa0b84cb0443d194c78daf12c2
Comment 1 Clifford Perry 2013-08-02 05:15:13 EDT
Stephen, please review and move to ON_QA, if it is indeed resolved (which we think it is (1.9)
Comment 7 Clifford Perry 2013-10-01 15:59:31 EDT
This bug was fixed with updated packages being released within the RHN Tools channels. 


RHN Tools (for Sat 5.6 GA) Errata text:

https://rhn.redhat.com/errata/RHEA-2013-1391.html

Note You need to log in before you can comment on or make changes to this bug.