Bug 90811 - RH 9 installer completely fails to install on Dell PowerEdge 2650
RH 9 installer completely fails to install on Dell PowerEdge 2650
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
9
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-13 23:33 EDT by Marc MERLIN
Modified: 2015-01-07 19:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 10:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc MERLIN 2003-05-13 23:33:58 EDT
Since you try to market RH as a server OS, maybe you should test it on the
common rack servers that people use it on? :-)

Data points:
RH 9 fails to install because it configures /dev/sda but the
kernel/fdisk is unable to access it
(this is something that I've never seen before)
RH 8 installs fine.
 
First guess:
The RH 9 kernel causes issues with ioapic/aic78xx/whatever
So, I spent quite a bit of time hacking the RH 8 kernel and boot modules
into the RH 9 installer
Well, that failed miserably in the same fashion, so it is somehow the RH
9 installer that wedges the system (even in expert/noprobe mode) so that
fdisk /dev/sda fails (the device is there, fdisk just can't talk to it)
 
Solution:
I then hacked the RH 8 installer to install the RH 9 RPMs instead.
Well, that just worked like a charm.

Of course, I have no idea what, in the RH 9 installer wedges /dev/sda,
especially since the RH 9 install still fails with the RH 8 kernel and modules.
Comment 1 Michael Fulbright 2003-05-14 12:30:31 EDT
After the installer inserts the driver for the scsi controller, if you switch to
VC2 and type 'less /tmp/syslog' does the driver show up in the kernel log?  Does
the drive show up?


Comment 2 Marc MERLIN 2003-05-14 12:48:25 EDT
Sorry, yes, I should have specified that.

The driver loads and the drives show up in the SCSI detection.

I've tried this with both the raid card (megaraid driver) and without (aic7xxx).
In both cases, the respective scsi driver scans the bus, sees the devices, the
installer creates /dev/sda, but any access to it fails.

Note that it shouldn't be a driver problem since the RH 8 kernel and driver
modules do fail in the same way in the RH9 installer, while they work with the
RH 8 installer.
Comment 3 Michael Fulbright 2003-05-20 12:13:15 EDT
If you get into the RHL 9 installer and got VC2 and run parted on /dev/sda does
it work ok?
Comment 4 Marc MERLIN 2003-05-20 14:05:12 EDT
I tried both
fdisk /dev/sda
and
even cat /dev/sda
They both failed even though the device existed and /dev/sda was shown in dmesg
after the SCSI driver got loaded
Comment 5 Michael Fulbright 2003-05-20 14:45:29 EDT
Ok this is most likely a kernel issue then if those commands will not work.

One last test - if you boot with 'linux rescue' and go into rescue mode w/o
mounting any existing filesystems does the parted /dev/sda work?
Comment 6 Marc MERLIN 2003-05-20 17:02:18 EDT
Please re-read my comments, I'm pretty sure it's not related since I
forward-ported the RH 8 install kernel to the RH 9 install floppy and second
stage  loader, and it still refused to install.
The RH 9 kernel also works fine once I get it installed with the RH 8 installer.

As for parted,
1) I didn't have any partitions mounted when I did my tests since the RH 9  
   installer could not access my drives/raid array
2) I can't do your tests anymore, I already lost more than one week due to this
   loading problem and having to fix your installer and the machines are in 
   production now. I can't reboot them or re-install them.
   I'm quite surprised that your QA departement doesn't have a sample of the
   most common rack servers that people are likely to use. You should go buy
   some, or have DELL/IBM send you one of each (I'm serious)
Comment 7 Michael Fulbright 2003-05-22 11:58:14 EDT
I believe this configuration should work based on other feedback we've received
but to be sure Jay has offered to verify it on one of our 2650's.  
Comment 8 Marc MERLIN 2003-06-10 11:41:54 EDT
Michael, thanks for looking into this.
Did you find anything out?
Comment 9 Marc MERLIN 2003-06-12 19:02:24 EDT
I got more info (I think).
Apparently, the server installs if you use a CD with all the drivers, but
it fails if you use a floppy which brings up the broadcom gige, does DHCP,
retreives stage 2 via NFS, and loads the SCSI modules from the stage two image.
The modules do load though, and the SCSI/RAID is detected.
For whatever reason, however, it does not register /dev/sda with the kernel
so any partitioning attempt after that, fails.

I haven't double checked, but _maybe_ the modules from the iso CD and the ones
in the second stage loader aren't identical.
Comment 10 Marc MERLIN 2003-06-13 14:24:28 EDT
Another option:
When you boot from an ISO, modules may get loaded in a different order than
if I boot a floppy that initializes the ethernet first, and then loads the
AIC/megaraid drivers after they've been retreived from stage 2.

Maybe there is a subtle bug when the scsi driver doesn't recognize the drives
if it's initialized after the ethernet or some other thing that happens first in
the installer
Comment 12 John Airey 2003-10-29 06:37:13 EST
I'm having a similar problem to this. I've managed a full install via CD, but 
installing via NFS causes a installer crash just after the NFS mount. I can 
install by FTP but this takes ages (I think it was 24 hours for a full 
install). I set the IP configuration manually (I don't use DHCP for installing 
servers).

I suspect the tg3 driver myself.

The 2650 I'm using has BIOS A16, ESM 1.01, PERC 3/DC 1.92 BIOS 3.3.1, ie it has 
four drives on a RAID controller.

I can do some tests as the machine isn't "live" yet. 
Comment 13 Jay Turner 2004-05-19 10:54:45 EDT
Issue is getting closed out in some spring cleaning as a result of
RHL9 no longer being a supported product.  Please reopen with comments
if you are continuing to see this issue with RHEL releases or Fedora.
Comment 14 John Airey 2004-05-20 04:33:45 EDT
The server I tested this on is now running RHEL AS and I had no 
problems installing it with kickstart.

Note You need to log in before you can comment on or make changes to this bug.