Bug 908112 - swt.jar doesn't contain any .class files
swt.jar doesn't contain any .class files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-05 17:16 EST by Edward Sheldrake
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 07:43:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Sheldrake 2013-02-05 17:16:37 EST
Description of problem:
swt.jar no longer contains any .class files, and as a result other programs like azureus that use swt by adding /usr/lib64/java/swt.jar to their java classpath fail to start.

Version-Release number of selected component (if applicable):
eclipse-swt-4.2.2-0.5.git20121217.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Try to launch azureus
2.
3.
  
Actual results:
java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:525)
	at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:114)
	at org.gudy.azureus2.ui.swt.Main.main(Main.java:292)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at com.aelitis.azureus.launcher.MainExecutor$1.run(MainExecutor.java:37)
	at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.NoClassDefFoundError: org/eclipse/swt/widgets/Listener
	at com.aelitis.azureus.ui.swt.Initializer.<init>(Initializer.java:164)
	... 12 more
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Listener
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
	at com.aelitis.azureus.launcher.classloading.PrimaryClassloader.loadClass(PrimaryClassloader.java:103)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
	... 13 more

Expected results:
azureus starts

Additional info:
The contents listing of swt.jar (from "jar t < /usr/lib64/java/swt.jar)":

org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/META-INF/
org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/about.html
org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/about_files/
org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/fragment.properties
org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/libswt-atk-gtk-4235.so
org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/libswt-awt-gtk-4235.so
org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/libswt-cairo-gtk-4235.so
org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/libswt-glx-gtk-4235.so
org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/libswt-gtk-4235.so
org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/libswt-pi-gtk-4235.so
org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/libswt-webkit-gtk-4235.so
org.eclipse.swt.gtk.linux.x86_64_3.100.1.v20130128-1024/org/
Comment 1 Fedora Update System 2013-02-06 06:16:31 EST
eclipse-4.2.2-0.7.git20121217.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eclipse-4.2.2-0.7.git20121217.fc18
Comment 2 Fedora Update System 2013-02-07 21:33:44 EST
Package eclipse-4.2.2-0.7.git20121217.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-4.2.2-0.7.git20121217.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2094/eclipse-4.2.2-0.7.git20121217.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-02-20 06:18:05 EST
eclipse-4.2.2-0.10.git20121217.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eclipse-4.2.2-0.10.git20121217.fc18
Comment 4 Fedora Update System 2013-02-27 13:44:50 EST
eclipse-4.2.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eclipse-4.2.2-2.fc18
Comment 5 Fedora Update System 2013-03-04 04:09:39 EST
eclipse-4.2.2-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eclipse-4.2.2-3.fc18
Comment 6 Krzysztof Daniel 2013-03-15 07:43:06 EDT
This has been fixed.
Comment 7 Fedora Update System 2013-03-15 07:52:13 EDT
eclipse-4.2.2-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eclipse-4.2.2-5.fc18
Comment 8 Fedora Update System 2013-03-19 16:03:50 EDT
eclipse-4.2.2-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.