Bug 90820 - new installation failure + workaround
new installation failure + workaround
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-14 06:38 EDT by Göran Schultz
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 19:10:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Schultz 2003-05-14 06:38:16 EDT
Description of problem:
RedHat9 - either CD or bootdisk.img floppy - iff ViewSonic VX-700 is connected
with the digital line, anaconda fails:  TFT screen looses contact with PC; no
problem when switching to analog VGA line

Version-Release number of selected component (if applicable):
RedHat9
monitor ViewSonic VX-700
PC ASUS P4PE with Pentium IV

How reproducible:
yes (many tries with all combinations)

Steps to Reproduce:
1. connect ViewSonic VX-700 with digital line to PC
2. make RedHat installation from floppy or CD
3.
    
Actual results:
monitor looses contact with PC

Expected results:


Additional info:
Have successfully installed on 4  other machines without problems
Comment 1 Michael Fulbright 2003-05-14 14:42:21 EDT
Which video card is in this system?
Comment 2 Göran Schultz 2003-05-14 16:50:53 EDT
The video card is an ASUS NVIDIA GEForce4 Ti 4200.

Here is an extract of my computer order last November, 2002:

1  1121 Logitech Cordless Mouseman Optical - ret     59.00e     3kpl
   1  1421 Samsung 3.5" 1.44MB mustanvärinen 3.5" x     11.50e     6kpl
   1  2120 Logitech Cordless Desktop Optical - must    122.00e    -6kpl
   1  2367 Microsoft Windows Me Eng OEM, uusi Mille    120.00e     2kpl
   1  3764 Asus P4PE ddr Lan Gold emolevy Intel Pen    202.00e    -1kpl
   1  5057 Aopen 56x (CD956E) sisäinen huippunopea      38.00e     5kpl
   1  5197 Aopen RW5120A DVD+RW asema sisäinenretai    401.00e     1kpl
   1  6326 Akasa Pax.Mate - akustisen melun imevä m     20.00e    12kpl
   1  6337 Verkkokauppa.com memory 512MB DDR 333MHz    165.90e    -9kpl
   1  7876 Asus V8420/DT 128MB GeForce4 Ti4200 VGA+    219.00e     0kpl
   1  8969 Seagate Barracuda IV 80GB - 1v takuu - A    146.00e     2kpl
   1  9103 Intel Pentium IV 1800MHz PGA478 0.13u OM    195.00e    -1kpl
Comment 3 Michael Fulbright 2003-05-20 15:00:28 EDT
Mike Harris - does XFree86 try to use the digital port for the LCD if it exists,
or does it always default to the analog VGA?
Comment 4 Mike A. Harris 2003-05-20 18:23:39 EDT
Each video card driver implements it's own monitor detection.  While
DDC is the standard mechanism, it is done slightly differently in each
driver, since the hardware implementation of this is different on different
hardware.  In addition, it may be different on different models of the same
card, with the same PCI ID.

In particular, it is known that Nvidia cards with the same PCI ID, may have
multiple i2c busses, and the hardware can be detected differently depending
on the exact card model.  There is no reliable way to have a single unique
configuration currently, however Nvidia is investigating better detection
for future XFree86 releases.

If an Nvidia card / monitor combo isn't detected and configured correctly,
users may need to read the "nv" driver manpage, and hand tune the configuration
slightly.  Extra help / tech support can be obtained from the
xfree86@xfree86.org mailing list also if required.

The rawhide version of XFree86 might be more robust with nv monitor detection,
as may be future releases.

This may or may not directly relate to the problem being described here, but I
have a feeling it is the same problem.

If you prefer, feel free to attach the non-working XFree86 config file and log
file, and I will investigate it a bit further to see if perhaps something else
is awry.

Thanks.
Comment 5 Mike A. Harris 2004-09-29 19:10:52 EDT
The 'nv' driver's experimental support for DVI panels was enhanced
in X.Org 6.7.0 and later releases of the X Window System.  As such,
this problem, caused by lack of driver support in XFree86 4.3.0,
is believed to now be resolved in our currently supported operating
system release of Fedora Core 2.

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.