Bug 908221 - $TERM too long - sorry.
Summary: $TERM too long - sorry.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: screen
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Hracek
QA Contact: Jan Kepler
URL:
Whiteboard:
: 1059533 (view as bug list)
Depends On:
Blocks: 947775 1070830 1075802 1159825
TreeView+ depends on / blocked
 
Reported: 2013-02-06 08:13 UTC by GV
Modified: 2019-07-11 07:38 UTC (History)
6 users (show)

Fixed In Version: screen-4.0.3-17.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 05:54:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1247 normal SHIPPED_LIVE screen bug fix and enhancement update 2015-07-20 17:50:15 UTC

Description GV 2013-02-06 08:13:40 UTC
Description of problem:
Unable to start screen when using rxvt-unicode-256color.
The error is: "$TERM too long - sorry."

Version-Release number of selected component (if applicable):
screen-4.0.3-16.el6.x86_64

Steps to Reproduce:
1. Install rxvt-unicode-256color (in my case fedora).
2. start urxvt256c.
3. verify that $TERM is rxvt-unicode-256color.
4. scp /usr/share/terminfo/r/rxvt-unicode-256color rhel6srv:.terminfo/r/
5. ssh rhel6srv.
6. start screen.
  
Additional info:
There is a patch for screen 4.0.3:
https://projects.archlinux.org/svntogit/packages.git/tree/screen/trunk/screen-4.0.3-long-term.patch

Also see the bug reported (and fixed) in fedora 18 https://bugzilla.redhat.com/show_bug.cgi?id=907472

Comment 3 RHEL Product and Program Management 2013-10-13 23:59:02 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 7 Petr Hracek 2014-11-28 09:37:09 UTC
*** Bug 1059533 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2015-07-22 05:54:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1247.html

Comment 11 GV 2015-07-22 06:01:38 UTC
Almost 2.5 years to fix a stupid bug...

Comment 12 Petr Hracek 2015-07-22 07:37:59 UTC
This is not about stupid bug but about capacities and priorities.
But feel free to use it. Hopefully without another bugs.

Comment 13 GV 2015-07-22 07:48:15 UTC
> But feel free to use it. Hopefully without another bugs.
Thx, but I fixed my screen rpm package 2.5 years ago. Thank you anyway.

Comment 14 Jani Ollikainen 2015-08-20 07:03:38 UTC
Well this wasn't nice.

FYI:
If you upgrade 6.6 -> 6.7 and you cannot attach to your screen anymore do a downgrade.

This patch changes the structs of the screen and after this patch you cannot attach screen running the old version.

wget http://vault.centos.org/6.6/os/x86_64/Packages/screen-4.0.3-16.el6.x86_64.rpm
yum downgrade screen-4.0.3-16.el6.x86_64.rpm

And do the upgrade after you have rebooted the machine, or before planned reboot.


Note You need to log in before you can comment on or make changes to this bug.