Bug 908233 - Package p11-kit-0.16.0
Package p11-kit-0.16.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: p11-kit (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kalev Lember
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks: 466626 915798
  Show dependency treegraph
 
Reported: 2013-02-06 03:40 EST by Upstream Release Monitoring
Modified: 2013-03-12 05:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 05:39:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update to upstream 0.16.0 version (2.32 KB, patch)
2013-03-05 04:16 EST, Stef Walter
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2013-02-06 03:40:52 EST
Latest upstream release: 0.15.1
Current version in Fedora Rawhide: 0.14
URL: http://p11-glue.freedesktop.org/releases/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Upstream Release Monitoring 2013-02-13 04:24:22 EST
Latest upstream release: 0.15.2
Current version in Fedora Rawhide: 0.14
URL: http://p11-glue.freedesktop.org/releases/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 2 Upstream Release Monitoring 2013-03-05 03:44:07 EST
Latest upstream release: 0.16.0
Current version in Fedora Rawhide: 0.14
URL: http://p11-glue.freedesktop.org/releases/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 3 Stef Walter 2013-03-05 04:16:58 EST
Created attachment 705345 [details]
Update to upstream 0.16.0 version
Comment 4 Stef Walter 2013-03-05 04:18:13 EST
Kalev, does the attached update look good?

Kai, this is the first package of p11-kit with the trust module in Fedora rawhide. We'll need to update the p11-kit-extract-trust script with the appropriate paths. We can do that as a separate update.
Comment 5 Kalev Lember 2013-03-05 05:57:51 EST
I think the new mkdir line isn't needed:

+mkdir -p $RPM_BUILD_ROOT%{_datadir}/p11-kit/modules

At that point, 'make install' will have already created the directory and installed p11-kit-trust.module in it. No need to duplicate the directory creation manually in the spec file if 'make install' already does it.

Otherwise looks good to me.
Comment 6 Stef Walter 2013-03-05 06:51:13 EST
Thanks for the review. Removed that line, and pushed to master.
Comment 7 Stef Walter 2013-03-12 05:39:05 EDT
Done.

Note You need to log in before you can comment on or make changes to this bug.