Bug 90828 - com.arsdigita.ui.login.UserInfo does sketchy caching of data objects
Summary: com.arsdigita.ui.login.UserInfo does sketchy caching of data objects
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Archit Shah
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 88926
TreeView+ depends on / blocked
 
Reported: 2003-05-14 13:09 UTC by Rafael H. Schloming
Modified: 2014-12-01 23:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 16:27:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rafael H. Schloming 2003-05-14 13:09:20 UTC
com.arsdigita.ui.login.UserInfo stores content centers and site nodes in member
variables (m_contentCenters and m_centerSiteNodes). The code that populates
these member variables is done on demand and inline with the request's
transaction. If the transaction of the request where these member variables are
populated is rolled back for any reason then the objects referenced from these
collections become invalid and all subsequent requests to the UserInfo component
fail with invalid data object errors.

Comment 1 Rafael H. Schloming 2003-05-14 16:14:48 UTC
It turns out that on the trunk this component causes an error on every request
other than the first one because data objects are no longer disconnected
automatically.


Note You need to log in before you can comment on or make changes to this bug.