Bug 908308 - Significant decrease in migration performance
Significant decrease in migration performance
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
: ZStream
Depends On: 904119 910554
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-06 06:49 EST by Jiri Pallich
Modified: 2013-03-07 03:39 EST (History)
10 users (show)

See Also:
Fixed In Version: ipa-3.0.0-26.el6_4
Doc Type: Bug Fix
Doc Text:
During migration, users were added to the default users group for each user added. Adding users to a group which had thousands consumed time and caused a significant performance slowdown. With this patch, users are now added in batches of 100, which provides a considerable performance boost over the previous method.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-07 03:39:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jiri Pallich 2013-02-06 06:49:35 EST
This bug has been copied from bug #904119 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 5 Scott Poore 2013-02-19 16:10:11 EST
Verified.

Version ::

ipa-server-3.0.0-26.el6_4.1.x86_64
389-ds-base-1.2.11.15-11.el6.x86_64

Automated Test Results ::

RHEL6.4.z Compat Enabled: 4 hrs 47 mins

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: SETUP FUNCTIONAL TESTING
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: Compat Plugin Enabled Mode :: 
:: [   LOG    ] :: kinit as admin with password PASSWORD was successful.
:: [   PASS   ] :: Get administrator credentials
:: [   PASS   ] :: Set migration mode to TRUE
:: [   LOG    ] :: Test Running with compat plugin Enabled
:: [   LOG    ] :: Duration: 13s
:: [   LOG    ] :: Assertions: 2 good, 0 bad
:: [   PASS   ] :: RESULT: SETUP FUNCTIONAL TESTING

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Migration 10000 users and 12 groups
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: slapd pid : 17882
:: [   LOG    ] :: Before migration free memory : 403640320
:: [   LOG    ] :: Before migration slapd VmRSS : 28044kB
:: [   LOG    ] :: Before migration slapd VmHWM : 28524kB
:: [   LOG    ] :: ======================= Migration started: Mon Feb 18 14:19:15 EST 2013 ========================
:: [   LOG    ] :: EXECUTING: time -p echo PASSWORD | ipa migrate-ds --with-compat ldap://ipaqavmc.testrelm.com:389
:: [   PASS   ] :: Migration completed successfully.
:: [   LOG    ] :: ======================= Migration finished: Mon Feb 18 19:06:25 EST 2013 ========================
:: [   LOG    ] :: slapd pid : 17882
:: [   LOG    ] :: After migration free memory : 119234560
:: [   LOG    ] :: After migration slapd VmRSS : 684304kB
:: [   LOG    ] :: After migration slapd VmHWM : 687764kB
:: [   LOG    ] :: Duration: 4h 47m 13s
:: [   LOG    ] :: Assertions: 1 good, 0 bad
:: [   PASS   ] :: RESULT: Migration 10000 users and 12 groups

RHEL6.4.z Compat Disabled:  4 hrs 24 mins

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: SETUP FUNCTIONAL TESTING
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: Compat Plugin Enabled Mode :: FALSE
:: [   LOG    ] :: kinit as admin with password PASSWORD was successful.
:: [   PASS   ] :: Get administrator credentials
:: [   PASS   ] :: Set migration mode to TRUE
:: [   LOG    ] :: Test Running with compat plugin Disabled
:: [   PASS   ] :: Turn off compat plugin
:: [   PASS   ] :: Restart directory server
:: [   LOG    ] :: Duration: 18s
:: [   LOG    ] :: Assertions: 4 good, 0 bad
:: [   PASS   ] :: RESULT: SETUP FUNCTIONAL TESTING

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Migration 10000 users and 12 groups
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: slapd pid : 19207
:: [   LOG    ] :: Before migration free memory : 400457728
:: [   LOG    ] :: Before migration slapd VmRSS : 22636kB
:: [   LOG    ] :: Before migration slapd VmHWM : 22636kB
:: [   LOG    ] :: ======================= Migration started: Tue Feb 19 11:20:36 EST 2013 ========================
:: [   LOG    ] :: EXECUTING: echo PASSWORD | ipa migrate-ds ldap://qe-blade-11.testrelm.com:389
:: [   PASS   ] :: Migration completed successfully.
:: [   LOG    ] :: ======================= Migration finished: Tue Feb 19 15:45:22 EST 2013 ========================
:: [   LOG    ] :: slapd pid : 19207
:: [   LOG    ] :: After migration free memory : 148611072
:: [   LOG    ] :: After migration slapd VmRSS : 637180kB
:: [   LOG    ] :: After migration slapd VmHWM : 640256kB
:: [   LOG    ] :: Duration: 4h 24m 48s
:: [   LOG    ] :: Assertions: 1 good, 0 bad
:: [   PASS   ] :: RESULT: Migration 10000 users and 12 groups
Comment 7 errata-xmlrpc 2013-03-07 03:39:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0606.html

Note You need to log in before you can comment on or make changes to this bug.