Bug 908380 - qt-at-spi module doesn't load due to kdeinit4 startup module linking issues
Summary: qt-at-spi module doesn't load due to kdeinit4 startup module linking issues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-workspace
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-06 14:55 UTC by Vitezslav Humpa
Modified: 2013-05-28 13:13 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-30 03:31:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 314185 None None None Never

Description Vitezslav Humpa 2013-02-06 14:55:07 UTC
Description of problem:
Please check the upstream bug for reproducers and more comments: https://bugs.kde.org/show_bug.cgi?id=314185

The qt-at-spi .so module does get ignored by the default kdeinit4 instance as run in 'starkde'. That is due to yet uknown issue with pre-linking the binaries there. That is, by default now, no applications run inside the KDE session using the kdeinit4 are a11y-accessible through the at-spi bus.

This can be worked around either by removing the LD_BIND_NOW=true from the kdeinit4 startup line in the startkde script:

LD_BIND_NOW=true /usr/libexec/kde4/start_kdeinit_wrapper +kcminit_startup -> /usr/libexec/kde4/start_kdeinit_wrapper +kcminit_startup

or

prelinking the libqspiaccessiblebridge.so with prelink prior the KDE startup:

$ prelink /usr/lib64/qt4/plugins/accessiblebridge/libqspiaccessiblebridge.so

Since the prelink is a no-option to add into qt-at-spi packaging, Kevin suggested we get rid of the LD_BIND_NOW in downstream startkde. But we should still get to the core of this.

Comment 1 Rex Dieter 2013-04-18 13:49:11 UTC
Per my #fedora-kde comment recently...

So, kinda forgot about this... for awhile

I'm thinking of implementing Kevin's suggestion of dropping LD_BIND_NOW from startkde.  I suspect that may also cure our other intermittent problems wrt prelink too.

any comments, objections, cheers of support? :)

Comment 2 Rex Dieter 2013-04-18 14:06:35 UTC
kde-workspace-4.10.2-5.fc20 building

* Thu Apr 18 2013 Rex Dieter <rdieter@fedoraproject.org> 4.10.2-5
- drop LD_BIND_NOW from startkde (#908380)
- fold all startkde-related patches into redhat_startkde.patch

will wait for some review, testing, and comment before proceeding to apply this to prior branches.

Comment 3 Fedora Update System 2013-04-23 14:53:27 UTC
kde-workspace-4.10.2-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kde-workspace-4.10.2-6.fc19

Comment 4 Fedora Update System 2013-04-26 14:44:07 UTC
kde-workspace-4.10.2-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kde-workspace-4.10.2-8.fc18

Comment 5 Fedora Update System 2013-04-27 00:00:52 UTC
Package kde-workspace-4.10.2-8.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-workspace-4.10.2-8.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6746/kde-workspace-4.10.2-8.fc18
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-04-30 03:31:18 UTC
kde-workspace-4.10.2-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2013-04-30 04:42:46 UTC
kde-workspace-4.10.2-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Vitezslav Humpa 2013-05-28 13:13:12 UTC
Definitely helped the a11y issue and other possible problems. Thanks!


Note You need to log in before you can comment on or make changes to this bug.