Bug 90839 - Could not find any linux partitions
Could not find any linux partitions
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-14 11:44 EDT by GeoffLeach
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-16 04:05:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description GeoffLeach 2003-05-14 11:44:43 EDT
Description of problem: In rescue mode.  All is well until Anaconda gets to
locating partitions.  Message: Could not find any linux partitions.  After
dropping into shell, I was able to mount / with no problems.  It is /dev/sda3
and its ext3.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Michael Fulbright 2003-05-15 14:43:34 EDT
What kind of controller is sda attached to, and did you see it load any SCSI
modules?
Comment 2 GeoffLeach 2003-05-15 15:01:02 EDT
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.3
The controller was recognized by Anaconda.  The aic7xxx driver was loaded.
Comment 3 Michael Fulbright 2003-05-20 15:01:30 EDT
Could you try booting with 'linux upgradeany'?
Comment 4 GeoffLeach 2003-05-20 16:52:44 EDT
I guess I wasn't clear on the sequence of events.  The upgrade proceeded without
any problem, so I assume that upgradeany would work OK as well.  It was the
_subsequent_ (ie after the upgrade was complete) of rescue mode where the
problem occurred.
Comment 5 Michael Fulbright 2003-05-22 12:05:40 EDT
The 'upgradeany' option relaxes our checking of potential partitions containing
your '/' filesystem. If for example you have removed or changed the
redhat-release contents.
Comment 6 GeoffLeach 2003-05-22 13:08:46 EDT
Hmmmm ... forgive me for being somewhat anal here, but ...
is it not the case that "linux upgradeany" will try to upgrade my installation?
And how will that affect the operation of "linux rescue"?

FWIW,
geoff@mtranch[6]->cat redhat-release
Red Hat Linux release 9 (Shrike)
Comment 7 Michael Fulbright 2003-05-23 12:27:44 EDT
The 'upgradeany' option just influcences how strict we are when trying to
auto-detect existing installations.  In rescue mode we use the same function to
find existing installations and offer to mount them for you.  The 'upgradeany'
option DOES NOT start an upgrade process if you also pass the 'rescue' option.

We probably need to have an alias for 'upgradeany' that isn't as daunting
sounding...
Comment 8 GeoffLeach 2003-05-30 15:25:30 EDT
"linux rescue upgradeany" found the two disks with bootable partitions and found
the root partition on the one selected.
Comment 9 Jeremy Katz 2003-06-16 04:05:42 EDT
Current code automatically relaxes the restrictions for rescue mode (since you
can chroot into whatever install you want as far as I'm concerned :)

Note You need to log in before you can comment on or make changes to this bug.