Bug 90844 - NFS and firewalls do not go nicely together.
NFS and firewalls do not go nicely together.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-14 12:38 EDT by Michal Jaegermann
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-19 08:08:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to the nfslock /etc/init.d start up script to improve firewall interation. (1.01 KB, patch)
2004-02-15 00:55 EST, Oliver Jones
no flags Details | Diff

  None (edit)
Description Michal Jaegermann 2003-05-14 12:38:30 EDT
Description of problem:

Due to random ports assignments one has to practically open all ports
in a firewall between machines talking NFS.  Some of components involved
can be asked to use fixed ports in /etc/sysconfig/ files but not all of
them.  Instead of a long description of troubles and remedies here I'd
rather refer to http://www.lowth.com/LinWiz/nfs_help.html which does that
better than I would. :-)  Some words on the subject in release notes
and/or docs also would be nice.

Yes, I know unofficial readings of "NFS" acronym.  Still...

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 2 Oliver Jones 2004-02-15 00:55:22 EST
Created attachment 97680 [details]
Patch to the nfslock /etc/init.d start up script to improve firewall interation.

This patch adds to /etc/rc.d/init.d/nfslock the ability for statd to pick up a
port number from /etc/sysconfig/nfs in the same way that mountd can.  This is
helpful for use with firewalls.

Note You need to log in before you can comment on or make changes to this bug.