Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 90848 - some nut and nut-client files belong in nut-cgi
some nut and nut-client files belong in nut-cgi
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nut (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-14 13:03 EDT by Gilbert E. Detillieux
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-09 11:27:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilbert E. Detillieux 2003-05-14 13:03:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030113

Description of problem:
Some files that should be in the nut-cgi package are in the wrong packages.  For
example, the nut package contains...

/usr/share/man/man8/upsimage.cgi.8.gz
/usr/share/man/man8/upsset.cgi.8.gz
/usr/share/man/man8/upsstats.cgi.8.gz

... and the nut-client package contains...

/etc/ups/hosts.conf
/etc/ups/upsset.conf
/usr/share/man/man5/hosts.conf.5.gz
/usr/share/man/man5/upsset.conf.5.gz
/usr/share/man/man5/upsstats.html.5.gz


Version-Release number of selected component (if applicable):
nut-1.2.0-6

How reproducible:
Always

Steps to Reproduce:
1. rpm -ql nut | grep cgi
2. rpm -ql nut-client | egrep 'hosts|upsset|upsstats'
3. rpm -ql nut-cgi
    

Expected Results:  All of the above files should actually be in the nut-cgi
package instead.

Additional info:

Also, the breakdown between nut and nut-client packages seems counter-intuitive.
 It seems it would make more sense for the nut-client package to actually be the
base "nut" package, since it's the one that's most likely going to be needed
(for either client or server).  The current "nut" package could instead be
called nut-server or nut-master, since it contains the programs/files needed
only on the master (system directly connected to the UPS).

However, changing it now may have implications for correctly upgrading to new
nut releases.
Comment 1 Tim Keitt 2003-06-22 14:19:48 EDT
I will second that. The current "nut-client" package _only needs_
"/etc/ups/upsmon.conf". All the other config file belong in either "nut" or
"nut-cgi". I do believe however that "nut-client" is a good name as its purpose
is to setup a client (slave) to monitor the master node with the UPS attached. 
Comment 2 Ngo Than 2003-09-09 11:27:34 EDT
It's fixed in 1.4.0-1, which will be available in rawhide. Thanks for your 
report 

Note You need to log in before you can comment on or make changes to this bug.